[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20080327194749.GA7633@cvg>
Date: Thu, 27 Mar 2008 22:47:49 +0300
From: Cyrill Gorcunov <gorcunov@...il.com>
To: "H. Peter Anvin" <hpa@...or.com>, Ingo Molnar <mingo@...e.hu>,
LKML <linux-kernel@...r.kernel.org>
Subject: processor flags
Hi Peter, Ingo
could you spend a few minutes on me? ;)
You know, I'm almost complete changing the vm86 flags
with X86_EFLAGS_... but there is a hidden problem lays.
Look, in vm86.h we have the definition
#ifdef CONFIG_VM86
#define VM_MASK 0x00020000
#else
#define VM_MASK 0 /* ignored */
#endif
which has an indirect conditional compilation effect.
For example, if we take a look on include/asm-x86/ptrace.h
static inline int v8086_mode(struct pt_regs *regs)
{
#ifdef CONFIG_X86_32
return (regs->flags & VM_MASK);
#else
return 0; /* No V86 mode support in long mode */
#endif
}
so if we don't have CONFIG_VM86 defined this function *always*
returning 0 so there I can't just change VM_MASK to X86_EFLAGS_VM.
Another piece of code from traps_32.c:do_general_protection
if (regs->flags & VM_MASK)
goto gp_in_vm86;
so if we didn't set CONFIG_VM86 i think this part is just thrown out
by gcc. So as we see, this VM_MASK original flag is not *just* a flag
but also says gcc which part of code to compile.
And now I'm in confusion - the way of changing this code I see is the
following:
- or use additional #ifdef CONFIG_VM86 in code where VM_MASK is used
(that would be ugly IMHO)
- rename VM_MASK to say X86_EFLAGS_VM86 with that #ifdef remained
- rest VM_MASK as it is
How do you think?
- Cyrill -
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists