[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20080327195656.GB7633@cvg>
Date: Thu, 27 Mar 2008 22:56:56 +0300
From: Cyrill Gorcunov <gorcunov@...il.com>
To: "H. Peter Anvin" <hpa@...or.com>
Cc: Ingo Molnar <mingo@...e.hu>, LKML <linux-kernel@...r.kernel.org>
Subject: Re: processor flags
[H. Peter Anvin - Thu, Mar 27, 2008 at 12:55:42PM -0700]
> Cyrill Gorcunov wrote:
>> And now I'm in confusion - the way of changing this code I see is the
>> following:
>> - or use additional #ifdef CONFIG_VM86 in code where VM_MASK is used
>> (that would be ugly IMHO)
>> - rename VM_MASK to say X86_EFLAGS_VM86 with that #ifdef remained
>> - rest VM_MASK as it is
>> How do you think?
>
> I think what we should do is:
>
> - Rename VM_MASK to X86_VM_MASK (it's x86-specific after all)
> - Have:
>
> #if CONFIG_VM86
> # define X86_VM_MASK X86_EFLAGS_VM
> #else
> # define X86_VM_MASK 0 /* No V86 support */
> #endif
>
> -hpa
>
Thanks a lot, Peter
- Cyrill -
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists