[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <200804080230.17426.arnd@arndb.de>
Date: Tue, 8 Apr 2008 02:30:16 +0200
From: Arnd Bergmann <arnd@...db.de>
To: joern@...fs.org
Cc: linux-kernel@...r.kernel.org, linux-fsdevel@...r.kernel.org,
linux-mtd@...ts.infradead.org
Subject: Re: [patch 1/15] Makefiles and Kconfig
On Tuesday 01 April 2008, joern@...fs.org wrote:
> --- linux-2.6.24logfs/fs/Kconfig~logfs 2008-03-24 12:39:10.190939342 +0100
> +++ linux-2.6.24logfs/fs/Kconfig 2008-04-01 19:48:18.517351063 +0200
> @@ -1385,6 +1385,23 @@ config JFFS2_CMODE_FAVOURLZO
>
> endchoice
>
> +config LOGFS
> + bool "Log Filesystem (EXPERIMENTAL)"
Is it really still the "Log Filesystem"? By now, I had the impression
that "logfs" is a name by itself, so it should be called the
"Logfs file system", and "config LOGFS_FS" respectively, like
JFFS2_FS, REISERFS_FS, AUTOFS_FS, UDF_FS etc.
> --- /dev/null 2008-03-30 12:15:48.586669308 +0200
> +++ linux-2.6.24logfs/fs/logfs/Makefile 2008-04-01 19:48:07.170961891 +0200
> @@ -0,0 +1,14 @@
> +obj-$(CONFIG_LOGFS) += logfs.o
> +
> +logfs-y += compr.o
> +logfs-y += dir.o
> +logfs-y += file.o
> +logfs-y += gc.o
> +logfs-y += inode.o
> +logfs-y += journal.o
> +logfs-y += memtree.o
> +logfs-y += readwrite.o
> +logfs-y += segment.o
> +logfs-y += super.o
> +logfs-$(CONFIG_BLOCK) += dev_bdev.o
> +logfs-$(CONFIG_MTD) += dev_mtd.o
You shouldn't add the Makefile and Kconfig before adding the actual
files, or you could cause git-bisect problems.
Arnd <><
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists