lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 23 Apr 2008 03:17:56 +0100
From:	David Woodhouse <dwmw2@...radead.org>
To:	Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Cc:	Cyrill Gorcunov <gorcunov@...il.com>, Ingo Molnar <mingo@...e.hu>
Subject: Re: x86: cleanup - rename VM_MASK to X86_VM_MASK

On Fri, 2008-04-18 at 18:56 +0000, Linux Kernel Mailing List wrote:
> Gitweb:     http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=6b6891f9c545ccd45d6d8ddfd33ce27c22c271a7
> Commit:     6b6891f9c545ccd45d6d8ddfd33ce27c22c271a7
> Parent:     6093015db2bd9e70cf20cdd23be1a50733baafdd
> Author:     gorcunov@...il.com <gorcunov@...il.com>
> AuthorDate: Fri Mar 28 17:56:57 2008 +0300
> Committer:  Ingo Molnar <mingo@...e.hu>
> CommitDate: Thu Apr 17 17:41:33 2008 +0200
> 
>     x86: cleanup - rename VM_MASK to X86_VM_MASK
>     
>     This patch renames VM_MASK to X86_VM_MASK (which
>     in turn defined as alias to X86_EFLAGS_VM) to better
>     distinguish from virtual memory flags. We can't just
>     use X86_EFLAGS_VM instead because it is also used
>     for conditional compilation
>     
>     Signed-off-by: Cyrill Gorcunov <gorcunov@...il.com>
>     Signed-off-by: Ingo Molnar <mingo@...e.hu>


> --- a/include/asm-x86/vm86.h
> +++ b/include/asm-x86/vm86.h
> @@ -17,9 +17,9 @@
>  #define IOPL_MASK	0x00003000
>  #define NT_MASK		0x00004000
>  #ifdef CONFIG_VM86
> -#define VM_MASK		0x00020000
> +#define X86_VM_MASK	X86_EFLAGS_VM
>  #else
> -#define VM_MASK		0 /* ignored */
> +#define X86_VM_MASK	0 /* No VM86 support */
>  #endif
>  #define AC_MASK		0x00040000
>  #define VIF_MASK	0x00080000	/* virtual interrupt flag */

This is user-visible. Yet we're changing the name and also making it
depend on #ifdef CONFIG_VM86, which is not going to be set in userspace.
Perhaps it should be within #ifdef __KERNEL__?

-- 
dwmw2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ