[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4823780D.2000406@goop.org>
Date: Thu, 08 May 2008 23:00:45 +0100
From: Jeremy Fitzhardinge <jeremy@...p.org>
To: Andrew Morton <akpm@...ux-foundation.org>
CC: segher@...nel.crashing.org, hancockr@...w.ca,
lists@...dbynature.de, linux-kernel@...r.kernel.org, mingo@...e.hu,
tglx@...utronix.de, johnstul@...ibm.com
Subject: Re: [PATCH] common implementation of iterative div/mod
Andrew Morton wrote:
> On Thu, 08 May 2008 16:16:41 +0100
> Jeremy Fitzhardinge <jeremy@...p.org> wrote:
>
>
>> We have a few instances of the open-coded iterative div/mod loop, used
>> when we don't expcet the dividend to be much bigger than the divisor.
>>
If you get a chance, could you fix the tpyo.
>> Unfortunately modern gcc's have the tendency to strength "reduce" this
>> into a full mod operation, which isn't necessarily any faster, and
>> even if it were, doesn't exist if gcc implements it in libgcc.
>>
>> The workaround is to put a dummy asm statement in the loop to prevent
>> gcc from performing the transformation.
>>
>> This patch creates a single implementation of this loop, and uses it
>> to replace the open-coded versions I know about.
>>
>
> Fair enough. I'll plan on feeding this into 2.6.26 soon.
>
>
>> #endif /* BITS_PER_LONG == 32 */
>> +
>> +/*
>> + * Iterative div/mod for use when dividend is not expected to be much
>> + * bigger than divisor.
>> + */
>> +unsigned iter_div_u64_rem(u64 dividend, u32 divisor, u64 *remainder)
>> +{
>> + unsigned ret = 0;
>> +
>> + while(dividend >= divisor) {
>> + /* The following asm() prevents the compiler from
>> + optimising this loop into a modulo operation. */
>> + asm("" : "+rm"(dividend));
>> +
>> + dividend -= divisor;
>> + ret++;
>> + }
>> +
>> + *remainder = dividend;
>> +
>> + return ret;
>> +}
>> +EXPORT_SYMBOL(iter_div_u64_rem);
>>
>>
>
> I think it would be better to do s/unsigned/u32/ here. It's cosmetic, but
> all this sort of code is pretty formal about the sizes of the types which
> it uses, and it sure needs to be.
>
OK.
J
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists