[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20080512122650.GA10014@logfs.org>
Date: Mon, 12 May 2008 14:26:51 +0200
From: Jörn Engel <joern@...fs.org>
To: Bryan Wu <bryan.wu@...log.com>
Cc: dwmw2@...radead.org, will.newton@...il.com,
linux-mtd@...ts.infradead.org, linux-kernel@...r.kernel.org,
Mike Frysinger <vapier.adi@...il.com>
Subject: Re: [PATCH try#2] [MTD/MAPS] Blackfin BF5xx Maps: Handle the case where flash memory and ethernet mac/phy are mapped onto the same async bank
On Sun, 3 February 2008 14:32:35 +0800, Bryan Wu wrote:
> +
> +static void bf5xx_copy_from(struct map_info *map, void *to, unsigned long from, ssize_t len)
> +{
> + unsigned long i;
> + map_word test;
> +
> + if ((unsigned long)to & 0x1) {
> + for (i = 0; i < len / 2 * 2; i += 2) {
> + test = bf5xx_read(map, from + i);
> + put_unaligned(test.x[0], (__le16 *)(to + i));
> + }
> + } else {
> + for (i = 0; i < len / 2 * 2; i += 2) {
> + test = bf5xx_read(map, from + i);
> + *((u16*)(to + i)) = test.x[0];
^^^^^^^^^^^^^^^^^
I'm not particularly fond of such constructs, maybe because I have such
a hard time understanding what the code actually does.
How about:
u16 *foo = to;
for (i = 0; i < (len & ~1); i++) {
test = bf5xx_read(map, from + 2 * i);
foo[i] = test.x[0];
}
With perhaps a better name than "foo" and the same conversion in the
rest of the function as well?
> + }
> + }
> +
> + if (len & 0x1) {
> + test = bf5xx_read(map, from + i);
> + *((u8*)(to + i)) = (u8)test.x[0];
> + }
> +}
Jörn
--
There's nothing better for promoting creativity in a medium than
making an audience feel "Hmm I could do better than that!"
-- Douglas Adams in a slashdot interview
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists