[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20080515130459.GA9650@in.ibm.com>
Date: Thu, 15 May 2008 18:34:59 +0530
From: Gautham R Shenoy <ego@...ibm.com>
To: Ingo Molnar <mingo@...e.hu>, npiggin@...e.de
Cc: linux-kernel@...r.kernel.org, Srivatsa Vaddagiri <vatsa@...ibm.com>
Subject: [PATCH] sched: Improve readability in update_cpu_load() code
Author: Gautham R Shenoy <ego@...ibm.com>
Date: Thu May 15 17:55:49 2008 +0530
sched: Improve readability in update_cpu_load() code
Currently the cpu_load[i] is calculated as:
this_rq->cpu_load[i] = (old_load*(scale-1) + new_load) >> i;
However, since scale = 2^i, this can be simplified as:
this_rq->cpu_load[i] = old_load + ((new_load - old_load) >> i);
Makes it easier to read.
Signed-off-by: Gautham R Shenoy <ego@...ibm.com>
diff --git a/kernel/sched.c b/kernel/sched.c
index 2d7d8f1..e1a6985 100644
--- a/kernel/sched.c
+++ b/kernel/sched.c
@@ -2921,7 +2921,7 @@ static void update_cpu_load(struct rq *this_rq)
*/
if (new_load > old_load)
new_load += scale-1;
- this_rq->cpu_load[i] = (old_load*(scale-1) + new_load) >> i;
+ this_rq->cpu_load[i] = old_load + ((new_load - old_load) >> i);
}
}
--
Thanks and Regards
gautham
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists