lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 29 May 2008 18:28:53 +0900 (JST)
From:	YOSHIFUJI Hideaki / 吉藤英明 
	<yoshfuji@...ux-ipv6.org>
To:	pomac@...or.com
Cc:	akpm@...ux-foundation.org, linux-kernel@...r.kernel.org,
	netdev@...r.kernel.org, yoshfuji@...ux-ipv6.org
Subject: Re: [ipv6] Odd behaviour...

In article <20080529084157.GD11812@...ac.netswarm.net> (at Thu, 29 May 2008 10:41:57 +0200), pomac@...or.com says:

> On Thu, May 29, 2008 at 12:27:29AM -0700, Andrew Morton wrote:
> > On Tue, 27 May 2008 00:58:30 +0200 Ian Kumlien <pomac@...or.com> wrote:
> > 
> > > Hi, 
> > > 
> > > I just recently acquired a new ipv6 tunnel since my two previous brokers
> > > has gone out of business. I now use hurricane electrics tunnel since i
> > > have really good ping times to it's node in Amsterdam.
> > > 
> > > Anyways, i have setup a local network tunnel and enabled forwarding.
> > > 
> > > After about 300 seconds, it all stops working. I have to disable and
> > > re-enable it on the firewall/router to get it working again.
> > > 
> > > tcpdump shows the router/firewall doing odd things like:
> > > (i renamed my host to piv6)
> > > 
> > > 00:48:14.294173 IP6 piv6 > igloo.stacken.kth.se: ICMP6, echo request,
> > > seq 321, length 64
> > > 
> > > 00:48:14.341288 IP6 igloo.stacken.kth.se > piv6: ICMP6, echo reply, seq
> > > 321, length 64
> > > 
> > > 00:48:14.341317 IP6 fe80::55e4:1b90 > igloo.stacken.kth.se: ICMP6,
> > > redirect, piv6 to piv6, length 160
> > > 
> > > 00:48:14.341332 IP6 igloo.stacken.kth.se > piv6: ICMP6, echo reply, seq
> > > 321, length 64
> > > ---
> > > 
> > > fe80::55e4::1b90 is the local ip of the ipv6 tunnel.
> > > (note: the packet never arrives at it's destination)
> > > 
> > > Any ideas of what could be going wrong?			
> > 
> > (cc netdev - afaik linux-net is kind of dead)
> 
> Thanks, i knew i missed something, -net was the one that was already in
> my email client so... =)
> 
> > What kernel version are you running?
> 
> The router/fw is running 2.6.25.1, the client is running 2.6.25.4
> 
> Any additional information i should provide?

How do you assign the address?

--yoshfuji
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists