lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 16 Jun 2008 16:39:37 +0900 (JST)
From:	kamezawa.hiroyu@...fujitsu.com
To:	Pavel Emelyanov <xemul@...nvz.org>
Cc:	KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>,
	linux-mm@...ck.org, LKML <linux-kernel@...r.kernel.org>,
	menage@...gle.com, balbir@...ux.vnet.ibm.com,
	yamamoto@...inux.co.jp, nishimura@....nes.nec.co.jp,
	lizf@...fujitsu.com
Subject: Re: Re: [PATCH 1/6] res_counter:  handle limit change

----- Original Message -----
>> +	 * registered callbacks etc...for res_counter.
>> +	 */
>> +	struct res_counter_ops ops;
>> +	/*
>
Now, write to limit is done in following path.
sys_write() -> write_func of subsys -> write in res_counter -> 
strategy callback -> set limit -> return

Because stragety callback is called in res_counter, we can only do 
something after set-limit without callback. So res_counter should call
another callback before set-limit if it can fail.

>Why would we need such? All res_counter.limit update comes via the appropiate
>cgroup's files, so it can do whatever it needs w/o any callbacks?
>

First reason is that this allows us to implement generic algorithm to
handle limit change. Second is that generic algorithm can be a stack of
functions. I don't like to pass function pointers through several stack
of functions. (And this design allow the code to be much easier to read.
My first version used an argument of function pointer but it was verrry ugly.)

I think when I did all in memcg, someone will comment that "why do that
all in memcg ? please implement generic one to avoid code duplication"

>And (if we definitely need one) isn't it better to make it a
>	struct res_counter_ops *ops;
>pointer?
>
My first version did that. When I added hierarchy_model to ops(see later patch
), I made use of copy of ops. But maybe you're right. Keeping 
res_counter small is important. I'll use pointer in v5.  

Thanks,
-Kame-

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ