[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4862CF57.1010106@goop.org>
Date: Wed, 25 Jun 2008 16:05:59 -0700
From: Jeremy Fitzhardinge <jeremy@...p.org>
To: Arjan van de Ven <arjan@...radead.org>
CC: Ingo Molnar <mingo@...e.hu>, LKML <linux-kernel@...r.kernel.org>,
x86@...nel.org, xen-devel <xen-devel@...ts.xensource.com>,
Stephen Tweedie <sct@...hat.com>,
Eduardo Habkost <ehabkost@...hat.com>,
Mark McLoughlin <markmc@...hat.com>
Subject: Re: [PATCH 03 of 36] x86: add memory barriers to wrmsr
Arjan van de Ven wrote:
> On Wed, 25 Jun 2008 14:08:57 -0700
> Jeremy Fitzhardinge <jeremy@...p.org> wrote:
>
>
>> Arjan van de Ven wrote:
>>
>>> it's more readable for several of these cases to stick a barrier();
>>> in front and after it to be honest; that makes it more explicit that
>>> these are deliberate compiler barriers rather than "actual" memory
>>> access...
>>>
>>>
>>>
>> I suppose, though I would be inclined to put the barriers in the
>> wrmsr macro itself to act as documentation.
>>
>
>
> yeah I meant like this:
>
> static inline void native_write_msr(unsigned int msr,
> unsigned low, unsigned high)
> {
> barrier();
> asm volatile("wrmsr" : : "c" (msr), "a"(low), "d" (high));
> barrier();
> }
>
> or in the same in the thing that calls this.
>
>
OK, we're in vehement agreement then.
J
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists