[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <48762397.5080000@redhat.com>
Date: Thu, 10 Jul 2008 11:58:31 -0300
From: Glauber de Oliveira Costa <gcosta@...hat.com>
To: Ingo Molnar <mingo@...e.hu>
CC: tglx@...utronix.de, hpa@...or.com, linux-kernel@...r.kernel.org,
x86@...nel.org
Subject: Re: [GIT PULL] Userlib integration patches
Ingo Molnar wrote:
> * Glauber Costa <gcosta@...hat.com> wrote:
>
>
>> Ingo, please pull the latest master git tree from:
>>
>> git://git.kernel.org/pub/scm/linux/kernel/git/glommer/linux-2.6-x86-integration.git master
>>
>> It is based on your tip/master tree, and contains an update to the
>> userlib integration according to the mailing list discussions. You
>> should be able to wipe out the previous branch, and put this one on
>> instead.
>>
>
> i've applied these changes to tip/x86/unify-lib:
>
> Glauber Costa (42):
> x86: don't use size specifiers.
> x86: provide delay loop for x86_64.
> x86: use rdtscll in read_current_timer for i386.
> x86: explicitly use edx in const delay function.
> x86: integrate delay functions.
> x86: don't clobber r8 nor use rcx.
> x86: don't use word-size specifiers.
> x86: adapt x86_64 getuser functions.
> x86: rename threadinfo to TI.
> x86: don't use word-size specifiers on getuser_64.
> x86: introduce __ASM_REG macro.
> x86: use _ASM_PTR instead of explicit word-size pointers.
> x86: merge getuser asm functions.
> x86: don't save ebx in putuser_32.S.
> x86: user put_user_x instead of all variants.
> x86: clobber rbx in putuser_64.S.
> x86: pass argument to putuser_64 functions in ax register.
> x86: change testing logic in putuser_64.S.
> x86: replace function headers by macros.
> x86: don't use word-size specifiers in putuser files.
> x86: use macros from asm.h.
> x86: merge putuser asm functions.
> x86: commonize __range_not_ok.
> x86: change asm constraint.
> x86: introduce likely in macro.
> x86: use long instead of int.
> x86: use something common for both architectures.
> x86: merge common parts of uaccess.
> x86: merge getuser.
> x86: move __addr_ok to uaccess.h.
> x86: use k modifier for 4-byte access.
> x86: mark x86_64 as having a working WP.
> x86: don't always use EFAULT on __put_user_size.
> x86: merge __put_user_asm and its user.
> x86: don't always use EFAULT on __get_user_size.
> x86: merge __get_user_asm and its users.
> x86: be more explicit in __put_user_x.
> x86: turn __put_user_check directly into put_user.
> x86: merge put_user.
> x86: move __get_user and __put_user into uaccess.h.
> x86: put movsl_mask into uaccess.h.
> x86: define architectural characteristics in uaccess.h.
>
> thanks Glauber, the finegrained splitup looks really nice!
>
> I had to rebase the series because it interacted with some other patches
> (such as the unification of tsc_[32|64].c => tsc.c).
So people keep doing things that were on my todo list ;-)
> It's being tested
> right now, will push it out into tip/master later today if everything
> goes fine.
> Ingo
>
Thanks ingo!
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists