lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 13 Jul 2008 02:43:33 +0100 (BST)
From:	"Maciej W. Rozycki" <>
To:	Yinghai Lu <>
cc:	Ingo Molnar <>, Thomas Gleixner <>,
	"H. Peter Anvin" <>,
	Suresh Siddha <>,
	LKML <>
Subject: Re: [PATCH] x86: let 32bit use apic_ops too

On Fri, 11 Jul 2008, Yinghai Lu wrote:

> -void apic_wait_icr_idle(void)
> +void xapic_wait_icr_idle(void)
>  {
>  	while (apic_read(APIC_ICR) & APIC_ICR_BUSY)
>  		cpu_relax();
>  }
> -u32 safe_apic_wait_icr_idle(void)
> +u32 safe_xapic_wait_icr_idle(void)

 Etc...  Why are you changing names of these functions?  Are they meant 
not to apply to older APIC implementations anymore?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists