[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <487D6E51.1000907@cn.fujitsu.com>
Date: Wed, 16 Jul 2008 11:43:13 +0800
From: Lai Jiangshan <laijs@...fujitsu.com>
To: Andrew Morton <akpm@...ux-foundation.org>
CC: Paul Jackson <pj@....com>, Paul Menage <menage@...gle.com>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: [PATCH 3/3] cpuset: two minor code-cleanups
in function cpuset_update_task_memory_state()
local variable
struct task_struct *tsk = current;
and local variable tsk is used 14 times and
statement task_cs(tsk) is used twice in this function.
So using task_cs(tsk) instead of task_cs(current) is
better for readability.
And "(struct cgroup_scanner *)&scan" is not good for
readability also. (and "container_of" is used in cpuset_do_move_task(),
not "(cpuset_hotplug_scanner *)scan")
Signed-off-by: Lai Jiangshan <laijs@...fujitsu.com>
---
diff --git a/kernel/cpuset.c b/kernel/cpuset.c
index 798b3ab..4513deb 100644
--- a/kernel/cpuset.c
+++ b/kernel/cpuset.c
@@ -369,7 +369,7 @@ void cpuset_update_task_memory_state(void)
my_cpusets_mem_gen = top_cpuset.mems_generation;
} else {
rcu_read_lock();
- my_cpusets_mem_gen = task_cs(current)->mems_generation;
+ my_cpusets_mem_gen = task_cs(tsk)->mems_generation;
rcu_read_unlock();
}
@@ -1778,7 +1778,7 @@ static void move_member_tasks_to_cpuset(struct cpuset *from, struct cpuset *to)
scan.scan.heap = NULL;
scan.to = to->css.cgroup;
- if (cgroup_scan_tasks((struct cgroup_scanner *)&scan))
+ if (cgroup_scan_tasks(&scan.scan))
printk(KERN_ERR "move_member_tasks_to_cpuset: "
"cgroup_scan_tasks failed\n");
}
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists