[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.1.10.0807180013190.4316@apollo.tec.linutronix.de>
Date: Fri, 18 Jul 2008 01:11:38 +0200 (CEST)
From: Thomas Gleixner <tglx@...utronix.de>
To: Linus Torvalds <torvalds@...ux-foundation.org>
cc: Andi Kleen <andi@...stfloor.org>,
Jesse Barnes <jbarnes@...tuousgeek.org>,
"Rafael J. Wysocki" <rjw@...k.pl>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
linux-acpi@...r.kernel.org, Ingo Molnar <mingo@...e.hu>
Subject: [PATCH] Revert duplicate "dock: bay: Don't call acpi_walk_namespace()
when ACPI is disabled" commit (was: Please pull ACPI updates)
On Thu, 17 Jul 2008, Linus Torvalds wrote:
> On Thu, 17 Jul 2008, Andi Kleen wrote:
> >
> > My plan was to keep everything in quilt and just regenerate for the pull.
> > Please let me know if it's now not allowed anymore to use quilt.
>
> End-point developers can use quilt all thei like.
>
> But people cannot and *MUST NOT* destroy other peoples work with quilt,
> nor make it harder for people to share commits.
>
> Len had apparently left a nice topic tree for you. You took that work, and
> then destroyed it. And yes, it is noticeable: Jesse had shared some of the
> work from Len by pulling one of the branches (the 'suspend' branch), and
> then you literally re-wrote _public_ history, so now tohose patches are
> duplicated.
It's not only about destroying work and history, it can be worse than that.
For example look at commits:
816c2eda3ce8fa7eb62f22e01e2ec7a3f7d677c0 (merged between 2.6.26-rc8 and -rc9)
and
cc7e51666d82aedfd6b9a033ca1a10d71c21f1ca (merged now)
The export to quilt and the lazy default fuzz setting of quilt added
aside of Andi's Signed-off-by the following gem:
commit cc7e51666d82aedfd6b9a033ca1a10d71c21f1ca
Author: Len Brown <len.brown@...el.com>
Date: Tue Jun 24 22:57:12 2008 -0400
dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled.
Signed-off-by: Len Brown <len.brown@...el.com>
Signed-off-by: Andi Kleen <ak@...ux.intel.com>
diff --git a/drivers/acpi/bay.c b/drivers/acpi/bay.c
index 61b6c5b..e6caf5d 100644
--- a/drivers/acpi/bay.c
+++ b/drivers/acpi/bay.c
@@ -380,6 +380,9 @@ static int __init bay_init(void)
if (acpi_disabled)
return -ENODEV;
+ if (acpi_disabled)
+ return -ENODEV;
+
/* look for dockable drive bays */
acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
ACPI_UINT32_MAX, find_bay, &bays, NULL);
diff --git a/drivers/acpi/dock.c b/drivers/acpi/dock.c
index bb7c51f..1e872e7 100644
--- a/drivers/acpi/dock.c
+++ b/drivers/acpi/dock.c
@@ -920,6 +920,9 @@ static int __init dock_init(void)
if (acpi_disabled)
return 0;
+ if (acpi_disabled)
+ return 0;
+
/* look for a dock station */
acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
ACPI_UINT32_MAX, find_dock, &num, NULL);
[ Note the code duplication in both files ]
I stumbled accross this incidentally while looking at the recent merge
commits.
While this one looks odd but harmless, probably a full audit of all
the affected commits should be done.
Please revert the one I happened to notice. Patch below.
Thanks,
tglx
----------->
Subject: APCI: revert duplicated patch
From: Thomas Gleixner <tglx@...utronix.de>
commit 816c2eda3ce8fa7eb62f22e01e2ec7a3f7d677c0
dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled.
was merged between 2.6.26-rc8 and -rc9)
Due to rebasing the ACPI tree via quilt the same patch got applied
again via
commit cc7e51666d82aedfd6b9a033ca1a10d71c21f1ca
dock: bay: Don't call acpi_walk_namespace() when ACPI is disabled.
Revert it, as it is obviously bogus.
Signed-off-by: Thomas Gleixner <tglx@...utronix.de>
---
diff --git a/drivers/acpi/bay.c b/drivers/acpi/bay.c
index e6caf5d..61b6c5b 100644
--- a/drivers/acpi/bay.c
+++ b/drivers/acpi/bay.c
@@ -380,9 +380,6 @@ static int __init bay_init(void)
if (acpi_disabled)
return -ENODEV;
- if (acpi_disabled)
- return -ENODEV;
-
/* look for dockable drive bays */
acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
ACPI_UINT32_MAX, find_bay, &bays, NULL);
diff --git a/drivers/acpi/dock.c b/drivers/acpi/dock.c
index 1e872e7..bb7c51f 100644
--- a/drivers/acpi/dock.c
+++ b/drivers/acpi/dock.c
@@ -920,9 +920,6 @@ static int __init dock_init(void)
if (acpi_disabled)
return 0;
- if (acpi_disabled)
- return 0;
-
/* look for a dock station */
acpi_walk_namespace(ACPI_TYPE_DEVICE, ACPI_ROOT_OBJECT,
ACPI_UINT32_MAX, find_dock, &num, NULL);
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists