[<prev] [next>] [day] [month] [year] [list]
Message-ID: <488ECF4A.6080200@goop.org>
Date: Tue, 29 Jul 2008 01:05:30 -0700
From: Jeremy Fitzhardinge <jeremy@...p.org>
To: Ingo Molnar <mingo@...e.hu>
CC: Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Nick Piggin <nickpiggin@...oo.com.au>,
Andi Kleen <andi@...stfloor.org>,
James Bottomley <James.Bottomley@...senPartnership.com>
Subject: [PATCH 0/4] unify arch/x86/kernel/tlb.c
This series converts tlb_32.c and _64.c to use smp_call_function_mask.
Having done that, their underlying similarity is plainly revealed, and
they can be easily unified.
The result is the removal of ~270 lines of code, most of which was a
pair of open-coded versions of what smp_call_function_mask does anyway.
The remaining code is much clearer as a result.
I've given these patches some mild testing, and nothing exploded. I'm
actually fairly confident in them, since all the complex subtle stuff is
now in smp_call_function_mask, so if anything breaks, it's probably
going to be in there.
And though I dare not touch it, Voyager could probably be converted to
use this code fairly simply as well.
J
--
arch/x86/kernel/Makefile | 2
arch/x86/kernel/entry_64.S | 15 --
arch/x86/kernel/irqinit_64.c | 10 -
arch/x86/kernel/tlb.c | 229 ++++++++++++++++++++++++++++++++++
arch/x86/kernel/tlb_32.c | 191 ----------------------------
arch/x86/kernel/tlb_64.c | 279 ------------------------------------------
arch/x86/kernel/tlb_uv.c | 5
include/asm-x86/irq_vectors.h | 4
include/asm-x86/uv/uv_bau.h | 2
9 files changed, 234 insertions(+), 503 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists