lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 07 Aug 2008 22:59:51 -0400
From:	David Dillow <dave@...dillows.org>
To:	Jaswinder Singh <jaswinder@...radead.org>
Cc:	David Woodhouse <dwmw2@...radead.org>,
	LKML <linux-kernel@...r.kernel.org>,
	Alan Cox <alan@...rguk.ukuu.org.uk>
Subject: Re: [GIT PULL]: firmware patches for building firmware into kernel

On Fri, 2008-08-08 at 07:08 +0530, Jaswinder Singh wrote:
> On Thu, 2008-08-07 at 14:21 -0400, David Dillow wrote:
> > Please drop that patch from the series for now; I'm not happy with it,
> > as it reintroduces things I've asked be changed. 
> 
> You mean this :
> 
> +       /*
> +        * Need to check request_firmware should be called only once
> +        * so you don't leak memory if there is more than one NIC.
> +        * Need to check if PCI probing gets multi-threaded as
> +        * mutex is used while loading the firmware.
> +        */
> +       if (typhoon_fw != NULL) {
> +               err = typhoon_init_firmware(tp);
> 
> This is not required now, As I already fixed request_firmware.
> 
> So it is replaced by :
> 
> +       err = typhoon_init_firmware(tp);
> 
> Do you think we still need above comments ?

No, the comments will be unneeded, but you don't need an extra function
to handle this, and I'm not real keen about the release_firmware_all()
interface -- it doesn't match up with the get/put semantics of the
reference count.

I don't like releasing the firmware before the pci_unregister_driver()
call. I worry about ordering issues during cleanup, though I'll admit I
have not yet researched if it will be a problem. In any event, if you're
going to request it once per adapter in typhoon_init_one(), then it
should be in the per-device struct, and released in
typhoon_remove_one().

Drop the typhoon patches, and once you fix the problems in the core,
I'll respin the patch in a style I'm comfortable with. It will also need
to be tested before it goes upstream.

Feel free to cc me on the core patches, I will try to review them.

Dave

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ