[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1221501260.16561.7.camel@nimitz>
Date: Mon, 15 Sep 2008 10:54:20 -0700
From: Dave Hansen <dave@...ux.vnet.ibm.com>
To: Oren Laadan <orenl@...columbia.edu>
Cc: arnd@...db.de, jeremy@...p.org, linux-kernel@...r.kernel.org,
containers@...ts.linux-foundation.org
Subject: Re: [RFC v5][PATCH 2/8] General infrastructure for checkpoint
restart
On Sat, 2008-09-13 at 19:06 -0400, Oren Laadan wrote:
>
> +int cr_read_obj_type(struct cr_ctx *ctx, void *buf, int n, int type)
> +{
> + struct cr_hdr h;
> + int ret;
> +
> + ret = cr_read_obj(ctx, &h, buf, n);
> + if (!ret) {
> + if (h.type == type)
> + ret = h.parent;
> + else
> + ret = -EINVAL;
> + }
> + return ret;
> +}
This one has been bugging me a bit. This adds one net line of code and
I think it's much easier to read:
{
struct cr_hdr h;
int ret;
ret = cr_read_obj(ctx, &h, buf, n);
if (ret)
return ret;
ret = -EINVAL;
if (h.type == type)
ret = h.parent;
return ret;
}
-- Dave
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists