lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 19 Sep 2008 15:22:13 +0800
From:	"Eric Miao" <eric.y.miao@...il.com>
To:	"Cyrill Gorcunov" <gorcunov@...il.com>
Cc:	"Alexey Dobriyan" <adobriyan@...il.com>,
	"Ben Dooks" <ben-linux@...ff.org>, linux-kernel@...r.kernel.org,
	linux-arm-kernel@...ts.arm.linux.org.uk
Subject: Re: kernel.h: add ARRAY_AND_SIZE() macro to complement ARRAY_SIZE().

On Fri, Sep 19, 2008 at 2:54 PM, Cyrill Gorcunov <gorcunov@...il.com> wrote:
> [Eric Miao - Fri, Sep 19, 2008 at 02:38:21AM +0800]
> | On Thu, Sep 18, 2008 at 11:06 PM, Alexey Dobriyan <adobriyan@...il.com> wrote:
> | > On Thu, Sep 18, 2008 at 02:24:47PM +0100, Ben Dooks wrote:
> | >> Move the ARRAY_AND_SIZE() macro from arch/arm/mach-pxa/generic.h
> | >> to a more useful position in include/linux/kernel.h. This macro
> | >> is very useful to registration functions that take an array and
> | >> the number of array elements in it as consecutive arguments.
> | >>
> | >> The macro also should ensure that mistakes where the wrong array
> | >> is used to the ARRAY_SIZE() macro is passed. It also makes it
> | >> easier to avoid wrapping registration function arguments.
> | >
> | >> --- linux-2.6.27-rc6-quilt4.orig/include/linux/kernel.h
> | >> +++ linux-2.6.27-rc6-quilt4/include/linux/kernel.h
> | >> @@ -43,6 +43,7 @@ extern const char linux_proc_banner[];
> | >>  #define IS_ALIGNED(x, a)             (((x) & ((typeof(x))(a) - 1)) == 0)
> | >>
> | >>  #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]) + __must_be_array(arr))
> | >> +#define ARRAY_AND_SIZE(arr) (arr), ARRAY_SIZE(arr)
> | >
> | > Just like ARRAY_SIZE, it is misnamed.
> | >
> |
> | Any hint about the correct spelling?
> |
> | > And it isn't obvious to what it expands. Hopefully arm people will
> | > remove it. :-)
> |
> | This is handy to use, saving several key strokes and making the line
> | shorter. If it's not obvious to what it expands, there must be some
> | fix for it?
> |
>
> well, it seems it's not that good to use ARRAY_AND_SIZE at all.
> Yes it's short but quite frankly - hiding number of args is not
> that good.
>
> example
>
>        static void ssp_send_cmd(uint32_t *cmd, int num);
>
> called as
>
>        ssp_send_cmd(ARRAY_AND_SIZE(lcd_panel_on));
>
> thanks it's not that spreaded across kernel.
> Someday it could lead to ARRAY_AND_SIZE_CHECK_IF_EXIST_AND_PANIC :)

Probably that not gonna happen.

without ARRAY_AND_SIZE:

        ssp_send_cmd(lcd_panel_on, ARRAY_SIZE(lcd_panel_on));

with:

        ssp_send_cmd(ARRAY_AND_SIZE(lcd_panel_on));

where you don't have to repeat the array name. I have to admit
that a macro expanding to something like an argument list instead
of a single variable or something  is not a good idea. But, we are
using C, and there's no easy way just to pass the array itself,
otherwise one may come up with:

        ssp_send_cmd(lcd_panel_on);

ssp_send_cmd(array a)
{
        int size = a.length();

........
}

I'm not trying to buy anyone anything, just illustrate this, and see
if anyone else is interested in doing so.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists