[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20080920144504.GB7354@localhost>
Date: Sat, 20 Sep 2008 18:45:04 +0400
From: Cyrill Gorcunov <gorcunov@...il.com>
To: Christer Weinigel <christer@...nigel.se>
Cc: Alexey Dobriyan <adobriyan@...il.com>,
Russ Dill <russ.dill@...il.com>,
Eric Miao <eric.y.miao@...il.com>,
linux-arm-kernel@...ts.arm.linux.org.uk,
Ben Dooks <ben-linux@...ff.org>, linux-kernel@...r.kernel.org
Subject: Re: kernel.h: add ARRAY_AND_SIZE() macro to complement
ARRAY_SIZE().
[Christer Weinigel - Sat, Sep 20, 2008 at 04:28:19PM +0200]
...
>
> In my opinion, making platform_add_devices into a magic macro is
> actually worse, since the same construct (array, ARRAY_SIZE(array)) is
> used in many places, so one would have to do the same thing over and
> over again for every function. In that case it's better to have to
> learn one macro once, and the ALL_CAPITALS should make it obvious that
> it is a macro.
>
> /Christer
>
Well, can't agree with you :) It's my _presonal_ opinion.
You could define it as
static inline int platform_add_devices_array(struct platform_device **devs)
{
return platform_add_devices(devs, ARRAY_SIZE(devs));
}
for me it would look much better then hide args by MACRO.
And I don't feel any hard about to use platform_add_devices
with TWO arguments. But I repeat - it's my _personal_ opinion.
- Cyrill -
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists