[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <48E189BF.4020907@jp.fujitsu.com>
Date: Tue, 30 Sep 2008 11:06:55 +0900
From: Kenji Kaneshige <kaneshige.kenji@...fujitsu.com>
To: Alex Chiang <achiang@...com>
CC: linux-pci@...r.kernel.org, linux-kernel@...r.kernel.org,
jbarnes@...tuousgeek.org, kristen.c.accardi@...el.com,
matthew@....cx
Subject: Re: [PATCH v3 02/14] PCI: prevent duplicate slot names
It seems my previous e-mail was not sent properly. So resending it.
Thanks,
Kenji Kaneshige
Kenji Kaneshige wrote:
> Hi Alex-san,
>
> Here is one comment, though I have not finished reviewing/testing
> your patches yet (sorry for the delay).
>
> Alex Chiang wrote:
>
> (snip.)
>
>> diff --git a/drivers/pci/hotplug/pci_hotplug_core.c
>> b/drivers/pci/hotplug/pci_hotplug_core.c
>> index 3e37d63..46802dc 100644
>> --- a/drivers/pci/hotplug/pci_hotplug_core.c
>> +++ b/drivers/pci/hotplug/pci_hotplug_core.c
>> @@ -570,39 +570,32 @@ int pci_hp_register(struct hotplug_slot *slot,
>> struct pci_bus *bus, int slot_nr,
>> return -EINVAL;
>> }
>>
>> - /* Check if we have already registered a slot with the same name. */
>> - if (get_slot_from_name(name))
>> - return -EEXIST;
>> -
>> /*
>> - * No problems if we call this interface from both ACPI_PCI_SLOT
>> - * driver and call it here again. If we've already created the
>> - * pci_slot, the interface will simply bump the refcount.
>> + * Look for existing slot. If we find it, and it was created by a
>> + * slot detection driver (ie, doesn't have a ->hotplug()) then we
>> + * allow the hotplug driver calling us to rename the slot if
>> desired.
>> + *
>> + * Otherwise, create the slot and carry on with life.
>> */
>> - pci_slot = pci_create_slot(bus, slot_nr, name);
>> - if (IS_ERR(pci_slot))
>> - return PTR_ERR(pci_slot);
>> -
>> - if (pci_slot->hotplug) {
>> - dbg("%s: already claimed\n", __func__);
>> - pci_destroy_slot(pci_slot);
>> - return -EBUSY;
>> + pci_slot = pci_get_pci_slot(bus, slot_nr);
>
> The pci_get_pci_slot() function refers pci_bus->slots list, so it
> should be called with pci_bus_sem semaphore held as pci_create_slot()
> does, or pci_bus_sem semaphore should be held by pci_get_pci_slot()
> itself.
>
> Thanks,
> Kenji Kaneshige
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists