lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Sat, 01 Nov 2008 21:54:13 +1000
From:	Adam Nielsen <a.nielsen@...kadi.net>
To:	Dmitry Melekhov <dm@...kam.com>
CC:	linux-kernel@...r.kernel.org
Subject: Re: serial port problem

> I connected zyxel modem to port and I see that it gets commsnds- it's
> data lamp blinks, but I get nothing.
> Situation is different on my colleague machine- since ubuntu 8.04 he can
> see in minicom or gtkterm how  connected router boots,
> but then he can't send someting over several port to router.
> I created bug report in ubuntu's launchpad, but there is no solution.
> As I now see this problem exists with kernel from kernel.org could you
> tell me how can I find where problem is?

I had a similar problem trying to get a dial-up modem working a couple 
of months ago.  I could use minicom to connect to the modem and type AT 
commands and read the responses, but whenever I dialled up I would see 
"CONNECT 48000" and that would be it.  I couldn't send or receive data 
from the other end.  After about a minute the ISP I was calling would 
time out and disconnect me.

I have no idea what the problem was, I even went to the trouble of 
buying extra serial ports on a PCI card thinking the hardware was 
faulty, but nothing helped.  In the end I downgraded to 2.6.17.8 (as 
this version was running on another PC that worked fine with the modem) 
and suddenly the whole thing worked perfectly.

So it looks like some bug was introduced into the serial driver at some 
point, and if you're having problems it must still be in the current 
kernel version.  I would suggest trying 2.6.17.8 instead (as that worked 
for me), and if it works for you too you might want to try upgrading 
until you find which version stops working - then we will know when the 
problem was first introduced.

Cheers,
Adam.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists