[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <491083E9.60305@ru.mvista.com>
Date: Tue, 04 Nov 2008 20:18:33 +0300
From: Sergei Shtylyov <sshtylyov@...mvista.com>
To: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
Cc: linux-ide@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/6] rz1000: apply chipset quirks early
Hello.
Bartlomiej Zolnierkiewicz wrote:
> From: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
> Subject: [PATCH] rz1000: apply chipset quirks early
> * Use pci_name(dev) instead of hwif->name in init_hwif_rz1000().
> * init_hwif_rz1000() -> rz1000_init_chipset(). Update rz1000_init_one()
> to use rz1000_init_chipset() and add now required rz1000_remove().
> * Remove superfluous ide_rz1000 chipset type.
> Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
> Index: b/drivers/ide/rz1000.c
> ===================================================================
> --- a/drivers/ide/rz1000.c
> +++ b/drivers/ide/rz1000.c
> @@ -22,34 +22,48 @@
>
> #define DRV_NAME "rz1000"
>
> -static void __devinit init_hwif_rz1000 (ide_hwif_t *hwif)
> +static unsigned int __devinit rz1000_init_chipset(struct pci_dev *dev)
Hm, this is not a real init_chipset() method and it does just one thing --
disables readahead, so rz1000_disable_readahead() or something of that sort
seems like a better name...
MBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists