lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <200811091503.48842.bzolnier@gmail.com>
Date:	Sun, 9 Nov 2008 15:03:48 +0100
From:	Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
To:	Sergei Shtylyov <sshtylyov@...mvista.com>
Cc:	linux-ide@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/6] rz1000: apply chipset quirks early

On Tuesday 04 November 2008, Sergei Shtylyov wrote:
> Hello, I wrote:
> 
> >> Index: b/drivers/ide/rz1000.c
> >> ===================================================================
> >> --- a/drivers/ide/rz1000.c
> >> +++ b/drivers/ide/rz1000.c
> >> @@ -22,34 +22,48 @@
> >>  
> >>  #define DRV_NAME "rz1000"
> >>  
> >> -static void __devinit init_hwif_rz1000 (ide_hwif_t *hwif)
> >> +static unsigned int __devinit rz1000_init_chipset(struct pci_dev *dev)
> 
> >    Hm, this is not a real init_chipset() method and it does just one 
> > thing -- disables readahead, so rz1000_disable_readahead() or something 
> > of that sort seems like a better name...
> 
>     Hm, 'unsigned' result type wasn't terribly helpful here as well. :-)

Agreed, v1->v2 interdiff:

...
v2:
* unsigned int rz1000_init_chipset() -> int rz1000_disable_readahead()
  per Sergei's suggestion.

Cc: Sergei Shtylyov <sshtylyov@...mvista.com>
...
diff -u b/drivers/ide/rz1000.c b/drivers/ide/rz1000.c
--- b/drivers/ide/rz1000.c
+++ b/drivers/ide/rz1000.c
@@ -22,7 +22,7 @@
 
 #define DRV_NAME "rz1000"
 
-static unsigned int __devinit rz1000_init_chipset(struct pci_dev *dev)
+static int __devinit rz1000_disable_readahead(struct pci_dev *dev)
 {
 	u16 reg;
 
@@ -52,7 +52,7 @@
 	if (rc)
 		return rc;
 
-	if (rz1000_init_chipset(dev)) {
+	if (rz1000_disable_readahead(dev)) {
 		d.host_flags |= IDE_HFLAG_SERIALIZE;
 		d.host_flags |= IDE_HFLAG_NO_UNMASK_IRQS;
 	}
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ