[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20081125155631.GA22006@elte.hu>
Date: Tue, 25 Nov 2008 16:56:31 +0100
From: Ingo Molnar <mingo@...e.hu>
To: Frédéric Weisbecker <fweisbec@...il.com>
Cc: Steven Rostedt <rostedt@...dmis.org>,
Linux Kernel <linux-kernel@...r.kernel.org>
Subject: Re: Human readable output for function return tracer
* Ingo Molnar <mingo@...e.hu> wrote:
>
> * Ingo Molnar <mingo@...e.hu> wrote:
>
> > > Do you agree with "full function tracer" (since we hook now on the
> > > two sides)?
> >
> > "full function tracer" sounds a bit funny and quirky. How about
> > "function call tracer"? Versus the "function tracer" or "function
> > entry tracer" which is the lighter variant - both in name and in
> > overhead. So we'd have:
> >
> > # cat /debug/tracing/available_tracers
> > mmiotrace wakeup irqsoff function function-call sysprof sched_switch initcall nop
> >
> > note how intuitive it is: "function-call" is 'more' than just the
> > plain function-tracer. It also expresses its main property: it
> > traces the full call, entry and exit and return code as well.
>
> another similar naming would be: the "function-graph" tracer.
> function-callgraph would be too long.
Steve thinks function-graph is even more expressive, so lets go with
that instead :)
it will certainly make sure there's no misunderstanding about the role
and scope of this tracer, and it's short and expressive as well.
so i'd suggest the following sed -i rules:
s/FUNCTION_RET_TRACER/FUNCTION_GRAPH_TRACER/g
i'd suggest to keep the ret_stack names - those are proper. (the thing
that is used to construct the graph is the return stack)
also, please do:
git mv kernel/tracing/trace_functions_return.c kernel/tracing/trace_functions_graph.c
and Makefile glue fixup:
s/functions_return/functions_graph/g
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists