lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 16 Dec 2008 16:17:30 +0100 (MET)
From:	"Peter T. Breuer" <ptb@....it.uc3m.es>
To:	"Johannes Weiner" <hannes@...xchg.org>
CC:	"linux kernel" <linux-kernel@...r.kernel.org>
Subject: Re: time_is_after_jiffies misnomer

"Also sprach Johannes Weiner:"
> On Tue, Dec 16, 2008 at 12:31:41PM +0100, Peter T. Breuer wrote:
> > 
> > I thought at first that
> > 
> >     time_is_after_jiffies(foo)
> > 
> > meant that the current time is later than foo jiffies.
> 
> 'foo jiffies'?


?? What does that mean? Yes, "the current time is later than foo
jiffies", is what I wrote. I don't understand why you query it. What I
wrote is a perfectly normal english sentence. It means "if the current
time is X and and the 

> It behaves like all the other time_(after|before) macros.  "Compare a
> given time T against some other time X".

It's poor english. Yes, to an english speaker

   time_is_after_jiffies(foo)

looks like

   the current time is later than foo jiffies

Look at the two:

   the current time is later than foo jiffies
                 |   |  |           `/.
               time_is_after_jiffies(foo)

(I AM a native english speaker, and a very good one - please take this
on board and pay attention to it; you'll find me quoted as the author
of hundreds of technical articles on google :-).

The mathematical "jiffies(foo)" for colloquial "foo jiffies" is the
normal way of writing formal predicates.  Like "colour(red)" for
"red colour". This is a predicate.

> T is always the first argument to these macros, it's never the current
> time.  This is consistent.

That's surely not relevant since it's the macro name that we are talking
about, nothing else.

As to "these macros", I see and know of no macros other than the set I
am commenting on. If you mean some others, you'll have to point them
out to me, but it wouldn't invalidate the observation: the macro names
are phrased the wrong way round for a natural english interpretation.


> And jiffies, the X here, is a well-known global variable. :)


> The banner comment above the macro group should have clarified the
> misunderstanding, btw.

No, it says nothing:

  * These four macros compare jiffies and 'a' for convenience.

What's written above the individual macros is more explanatory, but
it's the NAMES of the macros that are the wrong way round for english:

  
  /* time_is_before_jiffies(a) return true if a is before jiffies */
  #define time_is_before_jiffies(a) time_after(jiffies, a)

It's time_is_before_jiffies(foo) that reads the wrong way round in
english. It should be


     current_time_is_after_jiffies(foo).

Best regards


Peter
  

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ