[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <494801B3.9060203@nortel.com>
Date: Tue, 16 Dec 2008 13:29:55 -0600
From: "Chris Friesen" <cfriesen@...tel.com>
To: ptb@....it.uc3m.es
CC: Andreas Schwab <schwab@...e.de>,
linux kernel <linux-kernel@...r.kernel.org>
Subject: Re: time_is_after_jiffies misnomer
Peter T. Breuer wrote:
> Forgive me, but you don't seem to really be taking it on board here
> either ... what it SAYS to an english reader is the opposite of what
> you intend it to MEAN, unfortunately :(.
time_is_after_jiffies(foo) means: time "foo" is after the current value
of the variable "jiffies" (which is used throughout the kernel as the
current time).
You are interpreting it as: the current time is after time "foo" (which
is in jiffies).
The reason why your interpretation is incorrect is that "jiffies" is a
specific variable in and of itself, and not a modifier for "foo".
> So how about keeping the current macro
> names but gradually phasing them out in favour of a parallel set of
> alternatives, which could be
>
> current_time_is_before_jiffies(foo)
>
> ?? That reads fine in english and this time it means what it says!
You're using "jiffies" as a modifier for "foo", when it is actually a
separate variable. This makes your version just as ambiguous.
If you really want to change it, removing "jiffies" from the name (and
thus removing any ambiguity) may make more sense. Something like:
time_is_after(foo)
which would mean that the current value of "jiffies" is after "foo".
Chris
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists