[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20081218213633.GA20733@us.ibm.com>
Date: Thu, 18 Dec 2008 15:36:33 -0600
From: "Serge E. Hallyn" <serue@...ibm.com>
To: Sukadev Bhattiprolu <sukadev@...ux.vnet.ibm.com>
Cc: lkml <linux-kernel@...r.kernel.org>,
Linux Containers <containers@...ts.osdl.org>
Subject: Re: [PATCH 2/2] ipc namespaces: implement support for posix
msqueues
Quoting Sukadev Bhattiprolu (sukadev@...ux.vnet.ibm.com):
> | static int mqueue_get_sb(struct file_system_type *fs_type,
> | int flags, const char *dev_name,
> | void *data, struct vfsmount *mnt)
> | {
> | - return get_sb_single(fs_type, flags, data, mqueue_fill_super, mnt);
> | + if (flags & MS_KERNMOUNT)
> | + return get_sb_single_ns(fs_type, flags, data,
> | + mqueue_fill_super, mnt);
> | + return get_sb_single_ns(fs_type, flags, current->nsproxy->ipc_ns,
> | + mqueue_fill_super, mnt);
>
> nit. This maybe easier to read with an ns local variable and a single
> call to get_sb_single_ns().
The first time I read this I completely misunderstood what you
meant. Yes, that's nicer. Thanks for taking a look.
New version coming tomorrow (I want to stress this a bit).
thanks,
-serge
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists