[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.2.00.0901060808260.3057@localhost.localdomain>
Date: Tue, 6 Jan 2009 08:11:41 -0800 (PST)
From: Linus Torvalds <torvalds@...ux-foundation.org>
To: Ingo Molnar <mingo@...e.hu>
cc: Peter Zijlstra <peterz@...radead.org>,
Matthew Wilcox <matthew@....cx>,
Andi Kleen <andi@...stfloor.org>,
Chris Mason <chris.mason@...cle.com>,
Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org,
linux-fsdevel <linux-fsdevel@...r.kernel.org>,
linux-btrfs <linux-btrfs@...r.kernel.org>,
Thomas Gleixner <tglx@...utronix.de>,
Steven Rostedt <rostedt@...dmis.org>,
Gregory Haskins <ghaskins@...ell.com>,
Nick Piggin <npiggin@...e.de>
Subject: Re: [PATCH][RFC]: mutex: adaptive spin
On Tue, 6 Jan 2009, Linus Torvalds wrote:
>
> The other way around, you mean: we spin until the owner is no longer
> holding a cpu.
Btw, I hate the name of the helper function for that. "task_is_current()"?
"current" means something totally different in the linux kernel: it means
that the task is _this_ task.
So the only sensible implementation of "task_is_current(task)" is to just
make it return "task == current", but that's obviously not what the
function wants to do.
So it should be renamed. Something like "task_is_oncpu()" or whatever.
I realize that the scheduler internally has that whole "rq->curr" thing,
but that's an internal scheduler thing, and should not be confused with
the overall kernel model of "current".
Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists