[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090107190912.GB20311@us.ibm.com>
Date: Wed, 7 Jan 2009 13:09:12 -0600
From: "Serge E. Hallyn" <serue@...ibm.com>
To: Tetsuo Handa <penguin-kernel@...ove.sakura.ne.jp>
Cc: jmorris@...ei.org, akpm@...ux-foundation.org,
paulmck@...ux.vnet.ibm.com, linux-security-module@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [TOMOYO #14 (mmotm 2008-12-30-16-05) 02/10] Singly linked list
implementation.
Quoting Tetsuo Handa (penguin-kernel@...ove.sakura.ne.jp):
> James Morris wrote:
> > > Not all structures listed below are used as singly linked list,
> > > but many of them are used as singly linked list.
> >
> > Can any of these be converted to your singly linked list implementation ?
>
> Maybe, but will be few.
>
> Regular singly linked list (which is known as "slist") implementation has
> below characteristics.
>
> (1) Supports "add", "read" and "remove" operations.
> (2) Caller holds read lock when reading, and holds write lock when adding or
> removing.
> (3) Iteration method (for_each_*) needn't to call rcu_dereference() because
> caller holds locks as needed.
>
> TOMOYO's singly linked list (which is named as "list1") implementation has
> below characteristics.
>
> (1) Supports "add" and "read" operations.
> (2) Caller holds a lock when adding, but doesn't hold a lock when reading.
> (3) Iteration method (for_each_*) needs to call rcu_dereference() because
> caller doesn't hold a lock when reading.
>
> I think it is not a good thing to rename "list1" to "slist".
How about alist (or aolist) for append-only list?
The problem with list1 is that it *really* doesn't imply the
characteristics you cite.
-serge
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists