[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090118073453.GA714@redhat.com>
Date: Sun, 18 Jan 2009 08:34:53 +0100
From: Oleg Nesterov <oleg@...hat.com>
To: Andrew Morton <akpm@...ux-foundation.org>, jaharkes@...cmu.edu
Cc: "Eric W. Biederman" <ebiederm@...ssion.com>,
Pavel Emelyanov <xemul@...nvz.org>,
Sukadev Bhattiprolu <sukadev@...ux.vnet.ibm.com>,
linux-kernel@...r.kernel.org
Subject: [PATCH] coda: alloc_upcall: s/task_pgrp_nr/task_pgrp_vnr/
Needs an ack from maintaner, I do not know where coda_in_hdr->pgid is used.
alloc_upcall() is the last user of deprecated task_pgrp_nr(), change it
to use task_pgrp_vnr() instead. Or it really needs the pid_t from the global
namespace?
Signed-off-by: Oleg Nesterov <oleg@...hat.com>
--- CUR/fs/coda/upcall.c~3_CODA 2009-01-12 23:07:46.000000000 +0100
+++ CUR/fs/coda/upcall.c 2009-01-18 08:21:26.000000000 +0100
@@ -51,7 +51,7 @@ static void *alloc_upcall(int opcode, in
inp->ih.opcode = opcode;
inp->ih.pid = current->pid;
- inp->ih.pgid = task_pgrp_nr(current);
+ inp->ih.pgid = task_pgrp_vnr(current);
inp->ih.uid = current_fsuid();
return (void*)inp;
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists