[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <200902021948.04031.vapier@gentoo.org>
Date: Mon, 2 Feb 2009 19:48:01 -0500
From: Mike Frysinger <vapier@...too.org>
To: Adrian McMenamin <adrian@...golddream.dyndns.info>
Cc: greg KH <greg@...ah.com>, dwmw2 <dwmw2@...radead.org>,
Paul Mundt <lethal@...ux-sh.org>,
Dmitry Torokhov <dmitry.torokhov@...il.com>,
LKML <linux-kernel@...r.kernel.org>,
MTD <linux-mtd@...ts.infradead.org>,
"linux-sh" <linux-sh@...r.kernel.org>,
"linux-input" <linux-input@...r.kernel.org>
Subject: Re: [PATCH] sh: maple: Add support for VMU devices (v2) [1/3]
On Monday 02 February 2009 19:17:43 Adrian McMenamin wrote:
> + if (src_ofs >= ((card->parts)[partition]).numblocks * card->blocklen)
> + if (num > ((card->parts)[partition]).numblocks)
> + pcache = (card->parts[partition]).pcache;
ive only quoted some, but the use of parenthesis here is pointless and imo
makes the code harder to read. it's like trying to parse lisp ;).
> + vblock = kmalloc(sizeof(struct vmu_block), GFP_KERNEL);
sizeof(*vblock) ?
> +static int __init vmu_flash_map_init(void)
> +{
> + maple_driver_register(&vmu_flash_driver);
> + return 0;
> +}
shouldnt this be:
return maple_driver_register(&vmu_flash_driver);
-mike
Download attachment "signature.asc " of type "application/pgp-signature" (836 bytes)
Powered by blists - more mailing lists