[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.44L0.0903101019570.2962-100000@iolanthe.rowland.org>
Date: Tue, 10 Mar 2009 10:24:24 -0400 (EDT)
From: Alan Stern <stern@...land.harvard.edu>
To: Ingo Molnar <mingo@...e.hu>
cc: prasad@...ux.vnet.ibm.com,
Andrew Morton <akpm@...ux-foundation.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Roland McGrath <roland@...hat.com>
Subject: Re: [patch 00/11] Hardware Breakpoint interfaces
On Tue, 10 Mar 2009, Ingo Molnar wrote:
>
> There's also a few checkpatch warnings that need to be
> addressed:
>
> ERROR: do not use assignment in if condition
> #1084: FILE: arch/x86/kernel/ptrace.c:581:
> + else if ((thbi = alloc_thread_hw_breakpoint(tsk)) ==
> NULL)
Changing this to remove the assignment from within the "if" condition
would make the code less readable, not more. It's part of a long
series of tests; in schematic form:
if (n == 4 || n == 5)
...
else if (n == 6) {
...
}
else if (!tsk->thread.hw_breakpoint_info && val == 0)
...
else if ((thbi = alloc_thread_hw_breakpoint(tsk)) == NULL)
...
else if (n < HB_NUM) {
...
}
else
...
If you can suggest a way to change the code without making it worse,
I'm sure Prasad will be happy to adopt it.
Alan Stern
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists