lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1237794502.6313.21.camel@penberg-laptop>
Date:	Mon, 23 Mar 2009 09:48:22 +0200
From:	Pekka Enberg <penberg@...helsinki.fi>
To:	Lai Jiangshan <laijs@...fujitsu.com>
Cc:	Andrew Morton <akpm@...ux-foundation.org>,
	Christoph Lameter <cl@...ux-foundation.org>,
	Nick Piggin <npiggin@...e.de>,
	"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>,
	Manfred Spraul <manfred@...orfullife.com>,
	Ingo Molnar <mingo@...e.hu>,
	Peter Zijlstra <peterz@...radead.org>,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH -mm 1/6] slab: introduce __kfree_rcu

On Tue, 2009-03-03 at 21:44 +0800, Lai Jiangshan wrote:
> Introduce __kfree_rcu() for kfree_rcu()
> 
> We can calculate the object poiter from a poiter inside this
> object in slab.c, so we can use a portion_to_obj() to instead
> various container_of() for rcu callback and free the object.
> 
> Signed-off-by: Lai Jiangshan <laijs@...fujitsu.com>
> ---
> diff --git a/mm/slab.c b/mm/slab.c
> index 4d00855..a067d3f 100644
> --- a/mm/slab.c
> +++ b/mm/slab.c
> @@ -634,6 +634,17 @@ static inline unsigned int obj_to_index(const struct kmem_cache *cache,
>  	return reciprocal_divide(offset, cache->reciprocal_buffer_size);
>  }
>  
> +static inline void *portion_to_obj(void *portion)
> +{
> +	struct page *page = virt_to_head_page(portion);
> +	struct slab *slab = page_get_slab(page);
> +	struct kmem_cache *cache = page_get_cache(page);
> +	unsigned int offset = portion - slab->s_mem;
> +	unsigned int index = offset / cache->buffer_size;
> +
> +	return index_to_obj(cache, slab, index);
> +}

A minor nit: I think this would be more readable if you separated
variable declarations from the initializations. Also, you can probably
drop the inline from the function declaration and let GCC decide what to
do.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ