lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 23 Mar 2009 09:50:26 +0200
From:	Pekka Enberg <penberg@...helsinki.fi>
To:	Lai Jiangshan <laijs@...fujitsu.com>
Cc:	Andrew Morton <akpm@...ux-foundation.org>,
	Christoph Lameter <cl@...ux-foundation.org>,
	Nick Piggin <npiggin@...e.de>,
	"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>,
	Manfred Spraul <manfred@...orfullife.com>,
	Ingo Molnar <mingo@...e.hu>,
	Peter Zijlstra <peterz@...radead.org>,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH -mm 3/6] slub: introduce __kfree_rcu

On Tue, 2009-03-03 at 21:44 +0800, Lai Jiangshan wrote:
> Introduce __kfree_rcu() for kfree_rcu()
> 
> It like __kfree_rcu() in slab.c.
> We can calculate the object poiter from a poiter inside this
> object in slub.c, so we can use it for rcu callback and free
> the object.
> 
> Signed-off-by: Lai Jiangshan <laijs@...fujitsu.com>
> ---
> diff --git a/mm/slub.c b/mm/slub.c
> index 0280eee..b438ec5 100644
> --- a/mm/slub.c
> +++ b/mm/slub.c
> @@ -2756,6 +2756,30 @@ void kfree(const void *x)
>  }
>  EXPORT_SYMBOL(kfree);
>  
> +static void kfree_rcu_callback(struct rcu_head *rcu)
> +{
> +	void *portion = rcu;
> +	struct page *page = virt_to_head_page(portion);
> +
> +	if (unlikely(!PageSlab(page))) {
> +		BUG_ON(!PageCompound(page));

I'd prefer you did a WARN_ON() to increase the likelihood that people
will be able to copy-paste the oops for a bug report.

> +		put_page(page);
> +	} else {
> +		struct kmem_cache *s = page->slab;
> +		void *start = page_address(page);
> +		unsigned int index = (portion - start) / s->size;
> +		void *object = start + s->size * index;
> +

Again, I think the above would be more readable if you split the
variable initialization from the declaration.

> +		slab_free(s, page, object, _RET_IP_);
> +	}
> +}
> +
> +void __kfree_rcu(const void *x, struct rcu_head *rcu)
> +{
> +	call_rcu(rcu, kfree_rcu_callback);
> +}
> +EXPORT_SYMBOL(__kfree_rcu);
> +
>  /*
>   * kmem_cache_shrink removes empty slabs from the partial lists and sorts
>   * the remaining slabs by the number of items in use. The slabs with the
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ