[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <49CCBC07.6000004@linux.intel.com>
Date: Fri, 27 Mar 2009 12:44:07 +0100
From: Andi Kleen <ak@...ux.intel.com>
To: Hidetoshi Seto <seto.hidetoshi@...fujitsu.com>
CC: linux-kernel@...r.kernel.org, Ingo Molnar <mingo@...e.hu>
Subject: Re: [PATCH -tip 3/3] x86, mce: Add mce=nopoll option to disable timer
polling
Hidetoshi Seto wrote:
>> Also I'm not sure a boot argument is really needed. Isn't it
>> good enough to do this early at boot through sysfs?
>
> Maybe it is good for this option, as far as polling never run
> so soon. Because sysfs is available after start of polling
> timer, boot argument is required just in theory of logics.
I think the best way would be to just not run mcelog if you want
the BIOS to log all. The only problem I guess is that users might be confused
by the printk. So perhaps just do a patch to shut down the printk?
>
> One another problem is that there are multiple documentations for
> machinecheck parameters, but not linked well:
>
> - Documentation/kernel-parameters.txt
> ("See Documentation/x86/x86_64/boot-options.txt" for "mce=")
> - Documentation/x86/x86_64/boot-options.txt
> ("AMD64 specific boot options" is not true now!)
> - Documentation/x86/x86_64/machinecheck
> (which I had not noticed the existence at first, oops!)
machinecheck is for the sysfs interface, boot options is for the boot parameters.
I guess a reference could be added to machinecheck to point to boot-options.txt
Undoubtedly the documentation could be further improved too. In general machine
checks are rather tricky and somewhat unobvious though and I expect no matter how good
the documentation ever is it won't be easy to understand.
>>> static int check_interval = 5 * 60; /* 5 minutes */
>>> @@ -633,11 +635,12 @@ static void mce_init_timer(void)
>>> {
>>> struct timer_list *t = &__get_cpu_var(mce_timer);
>>>
>>> + /* Disable polling if check_interval is 0 */
>>> + if (!check_interval)
>>> + return;
>> This check shouldn't be needed, the next two checks already do that.
>
> That is for readability improvement.
it was actually a cheesy way to avoid a race with multiple initializers, but
I fixed this in a better way in a upcoming patch (now the interval is per CPU)
> + /* Disable polling if check_interval is 0 */
> + if (!check_interval)
> + return;
> /* data race harmless because everyone sets to the same value */
> if (!next_interval)
> next_interval = check_interval * HZ;
> - if (!next_interval)
> - return;
>
> Are there any case where the HZ becomes 0?
No.
-Andi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists