[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090402040537.GB30442@elte.hu>
Date: Thu, 2 Apr 2009 06:05:37 +0200
From: Ingo Molnar <mingo@...e.hu>
To: Tejun Heo <htejun@...il.com>
Cc: Eric Dumazet <dada1@...mosbay.com>,
Jeremy Fitzhardinge <jeremy@...p.org>,
linux kernel <linux-kernel@...r.kernel.org>,
Linux Netdev List <netdev@...r.kernel.org>,
Joe Perches <joe@...ches.com>,
Rusty Russell <rusty@...tcorp.com.au>
Subject: Re: [RFC] percpu: convert SNMP mibs to new infra
* Tejun Heo <htejun@...il.com> wrote:
> Hello, Eric, Ingo.
>
> Eric Dumazet wrote:
> > diff --git a/arch/x86/include/asm/percpu.h b/arch/x86/include/asm/percpu.h
> > index aee103b..6b82f6b 100644
> > --- a/arch/x86/include/asm/percpu.h
> > +++ b/arch/x86/include/asm/percpu.h
> > @@ -135,6 +135,9 @@ do { \
> > #define percpu_read(var) percpu_from_op("mov", per_cpu__##var)
> > #define percpu_write(var, val) percpu_to_op("mov", per_cpu__##var, val)
> > #define percpu_add(var, val) percpu_to_op("add", per_cpu__##var, val)
> > +#define indir_percpu_add(var, val) percpu_to_op("add", *(var), val)
> > +#define indir_percpu_inc(var) percpu_to_op("add", *(var), 1)
> > +#define indir_percpu_dec(var) percpu_to_op("add", *(var), -1)
> > #define percpu_sub(var, val) percpu_to_op("sub", per_cpu__##var, val)
> > #define percpu_and(var, val) percpu_to_op("and", per_cpu__##var, val)
> > #define percpu_or(var, val) percpu_to_op("or", per_cpu__##var, val)
>
> The final goal is to unify static and dynamic accesses but we
> aren't there yet, so, for the time being, we'll need some interim
> solutions. I would prefer percpu_ptr_add() tho.
Yep, that's the standard naming scheme for new APIs: generic to
specific, left to right.
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists