[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <1239115818-22035-1-git-send-email-jw@emlix.com>
Date: Tue, 7 Apr 2009 16:50:18 +0200
From: Johannes Weiner <jw@...ix.com>
To: Ben Dooks <ben-linux@...ff.org>
Cc: linux-kernel@...r.kernel.org
Subject: [patch] i2c-s6000: don't use device->bus_id directly
Use the dev_name() helper to get a name string for a device instead of
open-coding random device field accesses.
With '1fa5ae8 driver core: get rid of struct device's bus_id string
array' in place, this is not just a cleanup but a compilation fix.
Signed-off-by: Johannes Weiner <jw@...ix.com>
---
drivers/i2c/busses/i2c-s6000.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
Sorry, went unnoticed until the compilation broke on a newer kernel
with the above mentioned commit. Please apply.
diff --git a/drivers/i2c/busses/i2c-s6000.c b/drivers/i2c/busses/i2c-s6000.c
index c91359f..a19af51 100644
--- a/drivers/i2c/busses/i2c-s6000.c
+++ b/drivers/i2c/busses/i2c-s6000.c
@@ -276,7 +276,7 @@ static int __devinit s6i2c_probe(struct platform_device *dev)
}
iface->res = request_mem_region(iface->res->start,
resource_size(iface->res),
- dev->dev.bus_id);
+ dev_name(&dev->dev));
if (!iface->res) {
rc = -EBUSY;
goto err_out;
--
1.6.2.107.ge47ee
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists