lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 8 Apr 2009 15:18:30 +0800
From:	liqin.chen@...plusct.com
To:	linux-arch@...r.kernel.org, linux-kernel@...r.kernel.org
Cc:	torvalds@...ux-foundation.org, Arnd Bergmann <arnd@...db.de>,
	Sam Ravnborg <sam@...nborg.org>,
	Thomas Gleixner <tglx@...utronix.de>,
	Kyle McMartin <kyle@...artin.ca>
Subject: [PATCH 0/14] score - New architecure port to SunplusCT S+CORE

Hi tglx, Arnd, Kyle, Sam and linus,

According to your comment last week, We had updated the linux/score code,
use arch blackfin code as reference.
 
because some reasons below, I have not fixed these problems you mentioned
 
1:      bdflush is not a nop, remove it?

2:      because module_arch_cleanup, makcine_halt, machine_power_off and 
some other funcs are global, 
        so i have not move them into .h and not declare them as static 
inline.

3: 
> +#define __NR_exit                      (__NR_Linux +   1)
> +#define __NR_fork                      (__NR_Linux +   2)
> +#define __NR_read                      (__NR_Linux +   3)
> +#define __NR_write                     (__NR_Linux +   4)
> +#define __NR_open                      (__NR_Linux +   5)
> +#define __NR_close                     (__NR_Linux +   6)
> +#define __NR_waitpid                   (__NR_Linux +   7)
> +#define __NR_creat                     (__NR_Linux +   8)
> +#define __NR_link                      (__NR_Linux +   9)
> +#define __NR_unlink                    (__NR_Linux +  10)
> +#define __NR_execve                    (__NR_Linux +  11)
> +#define __NR_chdir                     (__NR_Linux +  12)
> +#define __NR_time                      (__NR_Linux +  13)
> +#define __NR_mknod                     (__NR_Linux +  14)
> +#define __NR_chmod                     (__NR_Linux +  15)
> +#define __NR_lchown                    (__NR_Linux +  16)
> +#define __NR_break                     (__NR_Linux +  17)
I still leave these syscalls there, bacause i think it clear to everybody
even linux have the new syscall replace them.

4:      asm/atomic.h and asm/bitops.h generic version have not finished,
        so I dont updated them.

5: 
> +#define __ARCH_WANT_SYS_FADVISE64
> +#define __ARCH_OMIT_COMPAT_SYS_GETDENTS64
> +#define __ARCH_WANT_IPC_PARSE_VERSION
> +#define __ARCH_WANT_OLD_READDIR
> +#define __ARCH_WANT_SYS_ALARM
> +#define __ARCH_WANT_SYS_GETHOSTNAME
> +#define __ARCH_WANT_SYS_PAUSE
> +#define __ARCH_WANT_SYS_SGETMASK
> +#define __ARCH_WANT_SYS_UTIME
> +#define __ARCH_WANT_SYS_WAITPID
> +#define __ARCH_WANT_SYS_SOCKETCALL
> +#define __ARCH_WANT_SYS_GETPGRP
> +#define __ARCH_WANT_SYS_LLSEEK
> +#define __ARCH_WANT_SYS_NICE
> +#define __ARCH_WANT_SYS_OLD_GETRLIMIT
> +#define __ARCH_WANT_SYS_OLDUMOUNT
> +#define __ARCH_WANT_SYS_SIGPENDING
> +#define __ARCH_WANT_SYS_SIGPROCMASK
> +#define __ARCH_WANT_SYS_RT_SIGACTION
> +#define __ARCH_WANT_STAT64
> +#define __ARCH_WANT_SYS_TIME
Once the kernel code update, I will remove these code.

6:      sys_sigaltstack should rename to sys_rt_sigaltstack?

7:      use score-linux compile linux/score kernel still have some 
warning, 
        but we think it not the problems in score head files.
 
8:      score have big and little endian support, now we only use 
        little endian running linux.


        score-linux toolchain could be download from
 
http://www.sunplusct.com/images/linux-score-patch/linux-score-20090324.patch
 
        linux/score lastest patch place at 
 
http://www.sunplusct.com/images/linux-score-patch/linux-score-20090324.patch

-- 
Best regards
Liqin
liqin.chen@...plusct.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ