lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 10 Apr 2009 09:40:39 +0530
From:	Jaswinder Singh Rajput <jaswinder@...nel.org>
To:	Matt Helsley <matthltc@...ibm.com>
Cc:	Alexey Dobriyan <adobriyan@...il.com>, akpm@...ux-foundation.org,
	containers@...ts.linux-foundation.org, xemul@...allels.com,
	linux-kernel@...r.kernel.org, dave@...ux.vnet.ibm.com,
	hch@...radead.org, mingo@...e.hu, torvalds@...ux-foundation.org
Subject: Re: [PATCH 09/30] x86_64: ifdef out struct thread_struct::ip

On Thu, 2009-04-09 at 20:53 -0700, Matt Helsley wrote:
> On Fri, Apr 10, 2009 at 06:35:22AM +0400, Alexey Dobriyan wrote:
> > struct thread_struct::ip isn't used on x86_64, struct pt_regs::ip is used
> > instead. 
> > 
> > kgdb should be reading 0, but I can't check it.
> > 
> > Signed-off-by: Alexey Dobriyan <adobriyan@...il.com>
> > ---
> > 
> >  arch/x86/include/asm/processor.h |    2 ++
> >  arch/x86/kernel/kgdb.c           |    2 +-
> >  2 files changed, 3 insertions(+), 1 deletion(-)
> > 
> > --- a/arch/x86/include/asm/processor.h
> > +++ b/arch/x86/include/asm/processor.h
> > @@ -421,7 +421,9 @@ struct thread_struct {
> >  	unsigned short		fsindex;
> >  	unsigned short		gsindex;
> >  #endif
> > +#ifdef CONFIG_X86_32
> >  	unsigned long		ip;
> > +#endif
> >  #ifdef CONFIG_X86_64
> >  	unsigned long		fs;
> >  #endif
> 
> Do these make struct thread_struct behave better in cachelines (smaller,
> less aliasing)? Can we really fit more in the slab du jour?
> 
> Otherwise it seems like we're littering these structs with #ifdefs
> and not really saving anything. If these #ifdefs don't save any space why not 
> just put in a comment:
> 
> >  	unsigned long		ip; /* Used only on i386 */
> 
> Or maybe even:
> 
> 	union {
> 	  	unsigned long		ip; /* Used only on i386 */
> 	  	unsigned long		fs; /* Used only on x86_64 */
> 	};
> 

Can we do it like this:
  	unsigned long		ip_fs; /* ip: i386, fs: x86_64 */

I am using same variable for both cases, or we can use some better name than ip_fs.
I am assuming either it is i386 or x86_64 machine ;-)

--
JSR


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ