[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090411223128.GO13936@josefsipek.net>
Date: Sat, 11 Apr 2009 18:31:28 -0400
From: Josef 'Jeff' Sipek <jeffpc@...efsipek.net>
To: Adrian McMenamin <adrian@...golddream.dyndns.info>
Cc: LKML <linux-kernel@...r.kernel.org>,
linux-fsdevel <linux-fsdevel@...r.kernel.org>,
viro <viro@...iv.linux.org.uk>,
linux-sh <linux-sh@...r.kernel.org>
Subject: Re: [RFC][patch] VMUFAT filesystem - v2
On Sat, Apr 11, 2009 at 11:11:31PM +0100, Adrian McMenamin wrote:
...
> diff --git a/fs/vmufat/inode.c b/fs/vmufat/inode.c
> new file mode 100644
> index 0000000..8ac0cba
> --- /dev/null
> +++ b/fs/vmufat/inode.c
...
> +#define VMUFAT_MAGIC 0x55555555
Last time I had a magic number lying around like that, I've been told to put
it in include/linux/magic.h.
...
> +struct memcard {
...
> +};
> +
> +struct vmufat_block_list {
...
> +};
Is this the code in a single file? Uf.
> +struct vmufat_file_info {
> + __u8 ftype;
> + __u8 copy_pro;
> + __u16 fblk;
> + char fname[12];
You had a #define for file name length near the top of the file. Why not use
it? :)
> +static inline int vmufat_index(int fno)
> +{
> + return (fno % 0x10) * 0x20;
> +}
> +
> +static inline int vmufat_index_16(int fno)
> +{
> + return (fno % 0x10) * 0x10;
> +}
I'd change the % and * to bit mask & shift.
Ok, I need to run out. I haven't seen the rest of the (rather long) patch.
Josef 'Jeff' Sipek.
--
Intellectuals solve problems; geniuses prevent them
- Albert Einstein
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists