lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:	Tue, 14 Apr 2009 09:50:15 +0800
From:	Peter Teoh <htmldeveloper@...il.com>
To:	LKML <linux-kernel@...r.kernel.org>
Subject: no_irq_type to no_irq_chip change

And looking into definition for no_irq_type (include/linux/irq.h):

/*
 * Migration helpers for obsolete names, they will go away:
 */
#define hw_interrupt_type       irq_chip
#define no_irq_type             no_irq_chip
typedef struct irq_desc         irq_desc_t;

We can see that "no_irq_type" is being made obsoleted:

For eg:

http://git.kernel.org/?p=linux/kernel/git/aegl/linux-2.6.git;a=blobdiff;f=arch/mn10300/kernel/irq.c;h=4c3c58ef5cda6fe571cbe39a649e8d4ebbfc3ae0;hp=50fdb5c16e0c34368e4faad479d041b4b4362eb9;hb=91e58b6e95a9c6b9efd928ae352eae5e75ae598c;hpb=df5529297ec4c32d57dd149398e3add6c37bc054

diff --git a/arch/mn10300/kernel/irq.c b/arch/mn10300/kernel/irq.c
index 50fdb5c..4c3c58e 100644 (file)
--- a/arch/mn10300/kernel/irq.c
+++ b/arch/mn10300/kernel/irq.c
@@ -140,7 +140,7 @@ void __init init_IRQ(void)
       int irq;

       for (irq = 0; irq < NR_IRQS; irq++)
-               if (irq_desc[irq].chip == &no_irq_type)
+               if (irq_desc[irq].chip == &no_irq_chip)
                       /* due to the PIC latching interrupt requests, even
                        * when the IRQ is disabled, IRQ_PENDING is superfluous
                        * and we can use handle_level_irq() for edge-triggered


But looking further into existing source:

./ia64/hp/sim/hpsim_irq.c:
               if (idesc->chip == &no_irq_type)

./ia64/sn/kernel/irq.c:
               if (base_desc[i].chip == &no_irq_type) {

./ia64/kernel/iosapic.c:
               if (idesc->chip != &no_irq_type)

./sh/kernel/sh_ksyms_32.c:
extern struct hw_interrupt_type no_irq_type;
EXPORT_SYMBOL(no_irq_type);


Does it make sense that I can change all these to no_irq_chip?
Purely naming change in nature.

Thanks.


-- 
Regards,
Peter Teoh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists