[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <14878.1239876272@redhat.com>
Date: Thu, 16 Apr 2009 11:04:32 +0100
From: David Howells <dhowells@...hat.com>
To: Oleg Nesterov <oleg@...hat.com>
Cc: dhowells@...hat.com, Andrew Morton <akpm@...ux-foundation.org>,
James Morris <jmorris@...ei.org>,
Roland McGrath <roland@...hat.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] rework/fix is_single_threaded()
Oleg Nesterov <oleg@...hat.com> wrote:
> - Fix the comment, is_single_threaded(p) actually means that nobody shares
> ->mm with p.
>
> I think this helper should be renamed,
What we want to know when we ask this function is whether or not a process is
single-threaded, hence the name. The fact that because:
CLONE_THREAD => CLONE_SIGHAND => CLONE_VM
we can work this out purely by checking that there aren't any processes that
share VM space with us is immaterial.
> and it should not have arguments. With or without this patch it must not be
> used unless p == current, otherwise we can't safely use p->signal or p->mm.
Well, I can live with that, but you need to check with the SELinux people too.
Whilst they do currently limit the selinux_setprocattr() to current only, they
still hand the task pointer that function is given around.
> - Use down_write(mm->mmap_sem) + rcu_read_lock() instead of tasklist_lock
> to iterate over the process list. If there is another CLONE_VM process
> it can't pass exit_mm() which takes the same mm->mmap_sem. We can miss
> a freshly forked CLONE_VM task, but this doesn't matter because we must
> see its parent and return false.
Hmmm... I'd quite like to avoid using down_write() if possible. Why do we
need to do this? Is it just to stop processes that might cease using mm from
doing so until we've finished?
David
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists