[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090418192314.GA22107@suse.de>
Date: Sat, 18 Apr 2009 12:23:14 -0700
From: Greg KH <gregkh@...e.de>
To: Yinghai Lu <yinghai@...nel.org>
Cc: Linus Torvalds <torvalds@...ux-foundation.org>,
Jesse Barnes <jbarnes@...tuousgeek.org>,
Andrew Morton <akpm@...ux-foundation.org>,
"H. Peter Anvin" <hpa@...or.com>, Ingo Molnar <mingo@...e.hu>,
Thomas Gleixner <tglx@...utronix.de>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
linux-pci@...r.kernel.org
Subject: Re: [PATCH] pci: keep pci device resource name pointer right.
On Sat, Apr 18, 2009 at 12:19:21PM -0700, Yinghai Lu wrote:
> Linus Torvalds wrote:
> >
> > On Fri, 17 Apr 2009, Yinghai Lu wrote:
> >> it turns that we need to reget res->name because dev->dev.kobj name is changed
> >> after device_add.
> >
> > Can we not make the rule be that the name should just be set before?
> >
> > IOW, there is something else broken, I think. Rather than put this ugly
> > band-aid, why now make sure that whoever had that broken name fixes it?
> >
>
> driver core guys are enforcing to use dev_name(device) instead of referring it.
By "enforcing" you now mean, "there is no other way" :)
> for pci code:
>
> via acpi_pci_root_driver.ops.add (aka acpi_pci_root_add) ==>
> pci_acpi_scan_root is used to scan pci bus/device, and at the same we
> read the resource for pci_dev at this point still need to use
> bus->devices to go over all pci_devices if needed.
> in the pci_read_bases, we have res->name = pci_name(pci_dev); pci_name
> is calling dev_name.
>
> later via acpi_pci_root_driver.ops.start (aka acpi_pci_root_start) ==>
> pci_bus_add_device to add all pci_dev in kobj tree.
>
> pci_bus_add_device will call device_add.
>
> actually in device_add
>
> /* first, register with generic layer. */
> error = kobject_add(&dev->kobj, dev->kobj.parent, "%s", dev_name(dev));
> if (error)
> goto Error;
>
> will get one new name for that kobj, old name is freed.
>
> Will try to make kobject_add more smart to reuse the old one.
I don't understand the problem here, how are you going to change the
kobject core? Is this just because you aren't getting a name for the
resource? If so, why would the driver core care about this?
confused,
greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists