[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090429131029.GA24485@elte.hu>
Date: Wed, 29 Apr 2009 15:10:29 +0200
From: Ingo Molnar <mingo@...e.hu>
To: mingo@...hat.com, hpa@...or.com, paulus@...ba.org,
linux-kernel@...r.kernel.org, robert.richter@....com,
a.p.zijlstra@...llo.nl, tglx@...utronix.de
Cc: linux-tip-commits@...r.kernel.org
Subject: Re: [tip:perfcounters/core] perf_counter, x86: rename
cpuc->active_mask
* tip-bot for Robert Richter <robert.richter@....com> wrote:
> Commit-ID: 93904966934193204ad08e951f806d5631c29eb3
> Gitweb: http://git.kernel.org/tip/93904966934193204ad08e951f806d5631c29eb3
> Author: Robert Richter <robert.richter@....com>
> AuthorDate: Wed, 29 Apr 2009 12:47:15 +0200
> Committer: Ingo Molnar <mingo@...e.hu>
> CommitDate: Wed, 29 Apr 2009 14:51:09 +0200
>
> perf_counter, x86: rename cpuc->active_mask
>
> This is to have a consistent naming scheme with cpuc->used.
>
> [ Impact: cleanup ]
>
> Signed-off-by: Robert Richter <robert.richter@....com>
> Cc: Paul Mackerras <paulus@...ba.org>
> Acked-by: Peter Zijlstra <a.p.zijlstra@...llo.nl>
> LKML-Reference: <1241002046-8832-19-git-send-email-robert.richter@....com>
> Signed-off-by: Ingo Molnar <mingo@...e.hu>
>
>
> ---
> arch/x86/kernel/cpu/perf_counter.c | 10 +++++-----
> 1 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/perf_counter.c b/arch/x86/kernel/cpu/perf_counter.c
> index 3f3ae47..9ec51a6 100644
> --- a/arch/x86/kernel/cpu/perf_counter.c
> +++ b/arch/x86/kernel/cpu/perf_counter.c
> @@ -29,9 +29,9 @@ static u64 perf_counter_mask __read_mostly;
> struct cpu_hw_counters {
> struct perf_counter *counters[X86_PMC_IDX_MAX];
> unsigned long used[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> + unsigned long active[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> unsigned long interrupts;
> u64 throttle_ctrl;
> - unsigned long active_mask[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> int enabled;
> };
Note, i applied this because later patches had dependencies - but
could you please send a followup patch that renames both ->used and
->active to ->used_mask and ->active_mask?
Thanks,
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists