[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.44L0.0905021010200.23879-100000@netrider.rowland.org>
Date: Sat, 2 May 2009 10:16:39 -0400 (EDT)
From: Alan Stern <stern@...land.harvard.edu>
To: David VomLehn <dvomlehn@...co.com>
cc: Sergey Vlasov <vsu@...linux.ru>,
Kernel development list <linux-kernel@...r.kernel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
USB list <linux-usb@...r.kernel.org>, Greg KH <greg@...ah.com>,
SCSI development list <linux-scsi@...r.kernel.org>,
<netdev@...r.kernel.org>, <arjan@...radead.org>
Subject: Re: [PATCH 1/5] initdev:kernel: Asynchronously-discovered device
synchronization, v5
I agree with Sergey's comments. In addition:
On Fri, May 01, 2009 at 07:25:51PM -0700, David VomLehn wrote:
> +initdev_wait(enum initdev_type type, bool (*done)(void))
> + Wait until one of two conditions is met:
> + o All possible init devices of the given type have been probed
> + o The "done" function returns true
> +
> + The type is one of:
> + BOOTDEV_CONSOLE
> + BOOTDEV_NETDEV
> + BOOTDEV_BLOCK
These should be named INITDEV_CONSOLE_TYPE and so on, with the final
_TYPE suffix to help prevent confusion with INITDEV_CONSOLE_MASK.
Also, in patch 3/5:
> --- a/drivers/accessibility/braille/braille_console.c
> +++ b/drivers/accessibility/braille/braille_console.c
> @@ -35,6 +35,7 @@
> #include <linux/keyboard.h>
> #include <linux/kbd_kern.h>
> #include <linux/input.h>
> +#include <linux/initdev.h>
What does this do? It looks like a typo.
Alan Stern
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists