[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1241431031.21088.21.camel@penberg-laptop>
Date: Mon, 04 May 2009 12:57:11 +0300
From: Pekka Enberg <penberg@...helsinki.fi>
To: Cyrill Gorcunov <gorcunov@...il.com>
Cc: David Rientjes <rientjes@...gle.com>, Ingo Molnar <mingo@...e.hu>,
Jack Steiner <steiner@....com>,
Andrew Morton <akpm@...ux-foundation.org>,
"H. Peter Anvin" <hpa@...or.com>,
Thomas Gleixner <tglx@...utronix.de>,
LKML <linux-kernel@...r.kernel.org>,
Christoph Lameter <cl@...ux-foundation.org>
Subject: Re: introducing __GFP_PANIC
On Mon, 2009-05-04 at 13:08 +0400, Cyrill Gorcunov wrote:
> Index: linux-2.6.git/mm/oom_kill.c
> =====================================================================
> --- linux-2.6.git.orig/mm/oom_kill.c
> +++ linux-2.6.git/mm/oom_kill.c
> @@ -422,6 +422,16 @@ static int oom_kill_process(struct task_
> return oom_kill_task(p);
> }
>
> +void oom_panic(gfp_t gfp_mask, unsigned int order)
> +{
> + if (likely(!(gfp_mask & __GFP_PANIC)))
> + return;
> +
> + panic("Out of memory: panic due to __GFP_PANIC.\n"
> + "%s order:%d, mode:0x%x\n", current->comm,
> + order, gfp_mask);
> +}
I think this just makes things harder to follow. It has one call-site so
why not inline this there?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists