[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1242389443-3470-1-git-send-email-philipp.reisner@linbit.com>
Date: Fri, 15 May 2009 14:10:27 +0200
From: Philipp Reisner <philipp.reisner@...bit.com>
To: linux-kernel@...r.kernel.org
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Jens Axboe <jens.axboe@...cle.com>, Greg KH <gregkh@...e.de>,
Neil Brown <neilb@...e.de>,
James Bottomley <James.Bottomley@...senPartnership.com>,
Sam Ravnborg <sam@...nborg.org>, Dave Jones <davej@...hat.com>,
Nikanth Karthikesan <knikanth@...e.de>,
"Lars Marowsky-Bree" <lmb@...e.de>,
"Nicholas A. Bellinger" <nab@...ux-iscsi.org>,
Kyle Moffett <kyle@...fetthome.net>,
Bart Van Assche <bart.vanassche@...il.com>,
Lars Ellenberg <lars.ellenberg@...bit.com>,
Philipp Reisner <philipp.reisner@...bit.com>
Subject: [PATCH 00/16] DRBD: a block device for HA clusters
Hi,
This is a repost of DRBD, to keep you updated about the ongoing
cleanups and improvements.
Patch set attached. Git tree available:
git pull git://git.drbd.org/linux-2.6-drbd.git drbd
We are looking for reviews!
Note for reviewers:
Only the first two patches (major.h and lru_cache) are self contained.
The other patches are just split at file boundaries. Sorry, DRBD
was developed as out-of-tree modules just for too long.
Short Description
DRBD is a shared-nothing, synchronously replicated block device. It
is designed to serve as a building block for high availability
clusters and in this context, is a "drop-in" replacement for shared
storage. Simplistically, you could see it as a network RAID 1.
More information can be found at http://www.drbd.org
Changes since 2009-04-30
* Cleanup: Removed typecasts, more documentation in lru_cache. Moved to /lib
* Cleanup: replaced __attribute__((packed)) with __packed
* Cleanup: remove quite a few 'inline's from .c files
* Cleanup: renaming a few constants: _SECT -> _SECTOR_SIZE, _SIZE_B -> _SHIFT ...
* Cleanup: rename inc_local -> get_ldev; inc_net -> get_net_conf; and corresponding dec_* -> put_*
* Cleanup: rename mdev->bc to mdev->ldev (to match the recent change to get_ldev/put_ldev)
* Cleanup: Made function comments kernel-doc compliant
* Cleanup: vmalloc() only as a fall back for kmalloc()
* DRBD: Allow detach of a SyncTarget node. (Bugz 221)
* DRBD: Call drbd_rs_cancel_all() and reset rs_pending when aborting resync due to detach. (Bugz 223)
* DRBD: make drbd thread t_lock irqsave - lockdep complained, and lockdep is right (theoretically)
Changes since 2009-04-10
* Cleanup: Removed all CamelCase
* Cleanup: Replaced DRBD's own tracing stuff with regular tracepoints
* Cleanup: Removed ERR/INFO/ALERT ... macros, using dev_err/dev_info/... now
* Cleanup: Minor stuff, as suggested in feedback on LKML
* DRBD: Bitmap compression feature was finalised
* DRBD: new disable_sendpage parameter
Changes since the post on 2009-03-30, all triggered by reviews
* Improvements to Makefile and Kconfig
* Simplified definitions of bm_flags' bitnumbers
* Removed debugging aid
Changes since the post on 2009-03-23, from drbd-mainline
* Updated to the final drbd-8.3.1 code
* Optionally run-length encode bitmap transfers
Changes since the post on 2009-03-23, triggered by reviews
* Using the latest proc_create() now
* Moved the allocation of md_io_tmpp to attach/detach out of drbd_md_sync_page_io()
* Removing the mode selection comments for emacs
* Removed DRBD_ratelimit()
cheers,
Phil
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists