[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4A1CA68B.4070609@cn.fujitsu.com>
Date: Wed, 27 May 2009 10:33:47 +0800
From: Li Zefan <lizf@...fujitsu.com>
To: Steven Rostedt <rostedt@...dmis.org>
CC: Ingo Molnar <mingo@...e.hu>, Jens Axboe <jens.axboe@...cle.com>,
Frederic Weisbecker <fweisbec@...il.com>,
Tom Zanussi <tzanussi@...il.com>,
"Theodore Ts'o" <tytso@....edu>,
Steven Whitehouse <swhiteho@...hat.com>,
KOSAKI Motohiro <kosaki.motohiro@...fujitsu.com>,
Jeff Moyer <jmoyer@...hat.com>,
Christoph Hellwig <hch@...radead.org>,
FUJITA Tomonori <fujita.tomonori@....ntt.co.jp>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v2 1/2] tracing/events: make __string() more general
>> Ah, it's pseudo code.. Should be construct_str(__entry->cmd, rq),
>> this helper function convert rq->cmd (unsigned char[]) to a string of
>> hex dump.
>>
>> No source string is available, so I'm not calling assign_str() in
>> TP_fast_assign.
>
> OK, I think I have a better understanding of what you are doing.
>
> But, I don't like changing the interface for string by adding that
> "strlen" to all users. I find that very ugly.
>
Yeah, it does look somewhat ugly..
> Could we instead perhaps add a __dynamic_array? That would take a length,
> and append itself to after the strings?
>
I thought about this actually. ;)
What troubled me is to give this new macro a better name.
We have __array() which is fixed-size, but __dynamic_array() is not
a dynamic-size version of __array(). How about __dyn_string() or
__dynamic_string()?
> stage 1:
>
> #define __dynamic_array(item, len) int __dyn_loc_##item;
>
> stage 2:
>
> #define __dynamic_array(item, len) int item;
>
> stage 3:
>
> #define __get_dynamic_array(item) \
> ((void *)__entry + __entry->__str_loc_##field
>
> stage 4:
>
> #define __dynamic_array(item, len) \
> __str_offsets.item = __str_size + \
> offsetof(typeof(*entry), __str_data); \
> __str_size += len;
>
Then we can make __string() reuse __dynamic_array().
>
> And so on. You should be able to do something like this, and make it more
> generic.
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists