[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20090616.120829.182011393.davem@davemloft.net>
Date: Tue, 16 Jun 2009 12:08:29 -0700 (PDT)
From: David Miller <davem@...emloft.net>
To: torvalds@...ux-foundation.org
Cc: eric.dumazet@...il.com, mingo@...e.hu, alan@...rguk.ukuu.org.uk,
akpm@...ux-foundation.org, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [GIT]: Networking
From: Linus Torvalds <torvalds@...ux-foundation.org>
Date: Tue, 16 Jun 2009 11:59:34 -0700 (PDT)
> At the very least, add a helper function for "do I actually have
> outstanding allocations" or something like that. IOW, do a
>
> /*
> * Comment here about that magical "1"
> */
> static inline int sk_has_allocations(struct sock *sk)
> {
> return atomic_read(&sk->sk_wmem_alloc) > 1 ||
> atomic_read(&sk->sk_rmem_alloc);
> }
>
> and then make the various network protocols use that, rather than
> open-coding some random internal implementation magic.
I agree, this should be handled with a helper function
abstraction rather than putting "1" checks all over the place.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists