[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.00.0906182327010.6890@gandalf.stny.rr.com>
Date: Thu, 18 Jun 2009 23:29:29 -0400 (EDT)
From: Steven Rostedt <rostedt@...dmis.org>
To: Frederic Weisbecker <fweisbec@...il.com>
cc: Jason Baron <jbaron@...hat.com>, linux-kernel@...r.kernel.org,
mingo@...e.hu, laijs@...fujitsu.com, peterz@...radead.org,
mathieu.desnoyers@...ymtl.ca, jiayingz@...gle.com,
bligh@...gle.com, roland@...hat.com, fche@...hat.com
Subject: Re: [PATCH 3/7] add syscall tracepoints
On Fri, 19 Jun 2009, Frederic Weisbecker wrote:
> On Fri, Jun 12, 2009 at 05:24:49PM -0400, Jason Baron wrote:
> >
> > Introduce a new 'DECLARE_TRACE_REG()' macro, so that tracepoints can associate
> > an external register/unregister function.
> >
> >
> > Signed-off-by: Jason Baron <jbaron@...hat.com>
> >
> > ---
> > include/linux/tracepoint.h | 27 +++++++++++++++++++++++----
> > 1 files changed, 23 insertions(+), 4 deletions(-)
> >
> > diff --git a/include/linux/tracepoint.h b/include/linux/tracepoint.h
> > index 14df7e6..9a3660b 100644
> > --- a/include/linux/tracepoint.h
> > +++ b/include/linux/tracepoint.h
> > @@ -61,7 +61,7 @@ struct tracepoint {
> > * not add unwanted padding between the beginning of the section and the
> > * structure. Force alignment to the same alignment as the section start.
> > */
> > -#define DECLARE_TRACE(name, proto, args) \
> > +#define DECLARE_TRACE_REG(name, proto, args, reg, unreg) \
>
>
>
> May be it deserves a comment? DECLARE_TRACE_REG() as a name is not enough
> obvious on its own :)
I agree. I was talking with Christoph Hellwig about doing something
similar with TRACE_EVENT, since he needs to do special things when enabled
and disabled (like enable other trace points).
But anyway, I totally NAK the name. What about something like
DECLARE_TRACE_WITH_CALLBACK()
Yes, it is a bit more verbose, but it at least tells what it does. The
first thing that came to my mind when I saw DECLARE_TRACE_REG, was that
this trace point will pass in "regs" to do things like backtraces.
-- Steve
>
>
>
> > extern struct tracepoint __tracepoint_##name; \
> > static inline void trace_##name(proto) \
> > { \
> > @@ -71,13 +71,29 @@ struct tracepoint {
> > } \
> > static inline int register_trace_##name(void (*probe)(proto)) \
> > { \
> > - return tracepoint_probe_register(#name, (void *)probe); \
> > + int ret; \
> > + void (*func)(void) = (void (*)(void))reg; \
> > + \
> > + ret = tracepoint_probe_register(#name, (void *)probe); \
> > + if (func && !ret) \
> > + func(); \
> > + return ret; \
> > } \
> > static inline int unregister_trace_##name(void (*probe)(proto)) \
> > { \
> > - return tracepoint_probe_unregister(#name, (void *)probe);\
> > + int ret; \
> > + void (*func)(void) = (void (*)(void))unreg; \
> > + \
> > + ret = tracepoint_probe_unregister(#name, (void *)probe);\
> > + if (func && !ret) \
> > + func(); \
> > + return ret; \
> > }
> >
> > +
> > +#define DECLARE_TRACE(name, proto, args) \
> > + DECLARE_TRACE_REG(name, TP_PROTO(proto), TP_ARGS(args), 0, 0);
> > +
> > #define DEFINE_TRACE(name) \
> > static const char __tpstrtab_##name[] \
> > __attribute__((section("__tracepoints_strings"))) = #name; \
> > @@ -94,7 +110,7 @@ extern void tracepoint_update_probe_range(struct tracepoint *begin,
> > struct tracepoint *end);
> >
> > #else /* !CONFIG_TRACEPOINTS */
> > -#define DECLARE_TRACE(name, proto, args) \
> > +#define DECLARE_TRACE_REG(name, proto, args, reg, unreg) \
> > static inline void _do_trace_##name(struct tracepoint *tp, proto) \
> > { } \
> > static inline void trace_##name(proto) \
> > @@ -108,6 +124,9 @@ extern void tracepoint_update_probe_range(struct tracepoint *begin,
> > return -ENOSYS; \
> > }
> >
> > +#define DECLARE_TRACE(name, proto, args) \
> > + DECLARE_TRACE_REG(name, TP_PROTO(proto), TP_ARGS(args), 0, 0);
> > +
> > #define DEFINE_TRACE(name)
> > #define EXPORT_TRACEPOINT_SYMBOL_GPL(name)
> > #define EXPORT_TRACEPOINT_SYMBOL(name)
> > --
> > 1.6.0.6
> >
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists